0

This question already has an answer here:

I have a pretty basic installation of Ubuntu 16.04 LTS. When I go to the launcher and select FILES a new screen opens. It has two parts to show some of the tree. In the left sidebar are five directories with unusual icons tied to them. I can delete the directories or rename them, but after deleting them they are still displayed. There is a "remove" option, but they are removed temporarily. As soon as FILES is re-opened the directories are back. The directories are not recognized from the terminal. I need to know how to eliminate them from appearing. Appreciate any answers.

marked as duplicate by Zanna, Ravexina, David Foerster, Elder Geek, user364819 May 9 '17 at 15:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you please clarify what the folder names are and what icons are showing? I think you're talking about the sidebar which should show your home folder, downloads, trash can, mounted hdd, etc...? – nullmeta May 6 '17 at 5:26
  • Yes, that is the page. The directory names were Downloads, Music, Videos, and two others. I don't remember their names. I renamed them Junk1 thru Junk5, since I won't be using them. The icons to the left of the names looks sort of like a manila folder. – Bernard Jensen May 6 '17 at 8:40
  • Those are "shortcut" folders for actual folders inside of your home directory, so they do exist and you can get to them from terminal. So you want to remove just those directories or remove the sidebar completely? – nullmeta May 6 '17 at 12:44
0

These are actual directories in your home folder. By default I believe it is:

  1. Home
  2. Desktop
  3. Documents
  4. Downloads
  5. Music
  6. Pictures
  7. Videos
  8. Trash

The sidebar Has them laid out as shortcuts. All of these are inside of /home/youruser

So for example you CAN access these from the terminal by either doing

cd /home/youruser/Documents

(or Pictures, Download,etc...) or by simply

cd ~/Documents

To hide the sidebar

The simple way to get rid of them is to hide them. When you open files, if you move your mouse to the top bar and click "files" You can uncheck "Sidebar" and the sidebar will disappear. Sidebar Option

That should make it look like this. No sidebar If you want to actually remove items from the sidebar you have to edit the user-dirs.dirs file.

Editing the file


Open a terminal and use your go-to file editing program, since I use nano my commands will be based on it.

nano ~/.config/user-dirs.dirs

You will see lines containing

XDG_DESKTOP_DIR="$HOME/Desktop"

and so on for every directory (Documents, Pictures, etc.) For the directories you would like to "remove" you have to change it to point simply at $HOME

XDG_DESKTOP_DIR="$HOME"

After finishing changing whichever directories you want gone, use ctrl-o to "write out" which means save, hit enter to save it, then ctrl-x to exit the editor. After this, logout and log back in After you open files the directories should be gone. (In my test on 17.04 they showed up again as another category underneath where they were previously in the sidebar, simply right clicking and removing them seemed to work across multiple logouts)

I hope this helps.

  • Your answer is very good, but it does not solve my problem. It is probably because I have done something stupid from the Terminal. I am not very knowledgeable about all this stuff. I'm just an old man who cannot keep up with things technical. I guess I will live with it, as is. Thanks. – Bernard Jensen May 7 '17 at 18:25
  • @BernardJensen Perhaps post a screen shot in your question so I can better understand exactly what you're seeing, and maybe edit it to say what you may have done in the terminal to cause it, or if it hasn't been like that since install, maybe edit to include certain things you think may have led up to the issue so I can edit my answer to try and better provide you a solution that works. – nullmeta May 7 '17 at 18:37
  • @BernardJensen that was just a path to a picture,actually edit your question, use the formatting tools to upload the picture into your question – nullmeta May 8 '17 at 3:16
  • I have no idea of how to access formatting tools. – Bernard Jensen May 8 '17 at 3:27
  • This website won't let me embed pictures, but I entered a link that I hope can be opened. Thanks. – Bernard Jensen May 8 '17 at 4:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.