1

My Fn key is permanently activated/pressed, although it is deactivated in the BIOS. In Ubuntu pressing the FN+ESC keys doesn't do anything. Numlock is deactivated in the BIOS, so it can't interfere with the Fn key.

I only want the FN functions upon pressing the FN key, hence any idea how to achieve this?

My machine is a Dell 9560 - latest UK version.

Ubuntu 16.04, latest standard updates, Kernel 4.8.0.51-generic.

1 Answer 1

2

I have managed to solve the problem. In Dell's boot options under 'POST Behaviour' --> 'Fn Lock Option' keep the check mark for 'Fn Lock' and below select 'Lock Mode Enable/Secondary'.

It seems wrong to select this because 'Lock Mode Enable/Secondary' is defined as:

The F1-F12 keys control the secondary functions. Fn is required to access the standard functions.

However, exactly the opposite is the case when selecting this option. F1-F12 work as function keys and only when Fn is pressed the secondary functions, e.g. volume down/up, brightness down/up, are triggered.

I found this solution on http://vetruvet.blogspot.de.

1
  • 1
    I use an apple wired keyboard, and it does not copy that bios setting; There is a linux kernel module that interacts with the settings of that keyboard: wiki.archlinux.org/title/… It is handy to set those defaults in the kernel commandline in grub, so your keyboard works fine immediately after booting.
    – Kai
    Jan 28 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.