A few months ago I started getting errors browsing the web in Ubuntu. I get the Resolving host error. It's very random, Sometimes I can use the internet for hours until the issue appears. Other days it doesn't work at all.

I've tried:

  • Use different browsers
  • Replace systemd-resolved with other DNS manager
  • Change DNS servers either by editing /etc/resolve.conf and using connection manager (lots of them)
  • Disable Ipv6

Thing I noticed:

  • I have a dual boot in my pc with windows 10. It works fine on windows
  • I don't have this issue on other devices (ipad, smartphone and ps4) so I guess it's not related to the router or internet signal
  • When it's working the speed is great
  • The issue affects the whole OS not just the browser.

Some logs:

$ cat /etc/resolv.conf nameserver

$ nmcli device show wlp5s0

GENERAL.DEVICE:                         wlp5s0
GENERAL.TYPE:                           wifi
GENERAL.HWADDR:                         08:D4:0C:A8:60:A6
GENERAL.MTU:                            0
GENERAL.STATE:                          100 (connected)
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/3
IP6.ADDRESS[1]:                         fe80::ad4:cff:fea8:60a6/64

$ cat /etc/systemd/resolved.conf

#FallbackDNS= 2001:4860:4860::8888 2001:4860:4860::8844

$ route

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         gateway         UG    600    0        0 wlp5s0   U     0      0        0 wlp5s0   U     600    0        0 wlp5s0

I don't know what else to do.

I had this issue on 16.10 and now on 17.04.

Any help will be appreciated.

  • Have you tried manually changing your DNS to opendns or google ones to see if there is any difference? I would also recommend test it whit dig as @MarkStosberg suggested. – dgonzalez May 5 '17 at 19:38
  • Yes, I've tried changing the DNS. dig times out no matter the dns server. – otaviosoares May 7 '17 at 2:05

First, you can simplify and isolate the issue. To simplify the issue, test as a close to "bare metal" as possible. In this case, you could test with "dig" instead of your browser.

To isolate if the issue is with customizations to your 17.04 system, you could boot the system from a Live USB that contains 17.04 (perhaps install media) and see if the issue still occurs in an unmodified environment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.