3

I have a folder in my Windows 10 host that needs to be shared with the Ubuntu 17.04 Virtualbox Guest.

Here's what I did:

  1. Added the windows folder to the VM's Shared Folders Folder Lst (Name: scraper, Auto-mount: Yes, Access: Full, Machine Folder)

  2. Added user to vboxsf group

    sudo usermod -a -G vboxsf scraper

  3. sudo mount -t vboxsf -o uid=1000,gid=1000 scraper /mnt/the-scraper

and encountered this

/sbin/mount.vboxsf: mounting failed with the error: No such file or directory

Why is this error happening? How can we solve this?

  • Add your user to the vboxusers group, then reboot the Host machine. If this doesn't work, try mounting the folder as root, inside the guest. – GTRONICK May 5 '17 at 16:44
4

You must log out, and log back in, for the vboxsf group to be enabled.

No implicit mount is required. If your Windows folder shows up in the Shared Folder icon at the bottom of the VB window, you just need to open a Nautilus window and click on the shared folder name in the left pane, or, in the Shared Folder setting, indicate that it should auto-mount.

Before doing your implicit mount, did you create the directory /mnt/the-scraper?

  • I have not created the directory /mnt/the-scraper. Is this simply mkdir /mnt/the-scraper? – Nyxynyx May 5 '17 at 18:46
  • Yes. Or use sudo if you want the drive mounted as root. And you should probably be using the /media/the-scraper rather than /mnt. – heynnema May 5 '17 at 18:47
  • After restarting the VM, I dont see the shared folder name in the left panel of Nautilus window. – Nyxynyx May 5 '17 at 19:26
  • However, after creating the directory /media/the-scraper, the initial mount command that I tried successfully mounted the shared foler – Nyxynyx May 5 '17 at 19:27
  • You can also tell the Shared Folder to auto-mount in the settings. – heynnema May 5 '17 at 19:27
1

What seems to have helped in my case (I needed to remount automounted dir ws with proper user as owner):

  1. Create directory that I wanted to mount it to (/mnt/rews):

    sudo mkdir /mnt/rews
    
  2. Set max permissions to the created dir:

    sudo chown artyhedgehog:artyhedgehog /mnt/rews
    sudo chmod 777 /mnt/rews
    
  3. Got this error when tried mounting:

    $ sudo mount -t vboxsf -o remount,gid=1000,uid=1000,rw ws /mnt/rews     
    /sbin/mount.vboxsf: mounting failed with the error: Invalid argument
    
  4. So I unmounted automount by VirtualBox and mounted back manually - and it worked:

    sudo umount ws
    sudo mount -t vboxsf -o gid=1000,uid=1000,rw ws /mnt/rews        
    

P.S. Windows 10 on host, VirtualBox 6.0.8, Ubuntu 18.04 LTS on VM, VirtualBox Guest Additions installed via VirtualBox instance menu, Shared Folder set up with "Folder Name": ws, "Auto-mount": checked, "Make Permanent": checked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.