0

I have installed MS Office 2007 via playonlinux because I have a particular file that does not play nicely when saved in Libreoffice. I do all my work in Libreoffice and subsequently copy one sheet from Libreoffice into Excel. However, even though my number locale is set to continental European standards (thousands are separated by dots and decimals by comma), Excel uses US English Number formats (and hence recognizes the pasted values as text).

I already have a workaround (find and replace). However, I would prefer the file to open with more sane (from a European perspective) number defaults.

The desktop file contains the following exec part

Exec= /usr/share/playonlinux/playonlinux --run "Microsoft Office Excel 2007" %F

I tried modify it to

Exec=LANG=el_EL.UTF-8 /usr/share/playonlinux/playonlinux --run "Microsoft Office Excel 2007" %F   

to no avail.

PS: I have in the meantime found another workaround (change the settings in MS Excel itself. However, I still hope for an answer that will work irrespective of the particular Windows program providing such options.

  • 3
    have you tried setting this in excel's own option? this is a reccurent windows issue I have : Office doesn't give a rat's ass what language or locale your windows is in; it will install it's own. It's not something that changing the windows locale will have any influence on. – tatsu May 11 '17 at 7:27
  • Yes, that is a workaround I currently used (actually found out only today). – Bruni May 11 '17 at 7:30
  • isn't it permanent? – tatsu May 11 '17 at 7:35
  • @tatsu It is permanent. I just left the question because I hoped for a more application independent solution. However, if you say that Office does not respect the OS language settings even on windows, than such a solution would not work for Office anyway. Please add your comment as an answer. – Bruni May 11 '17 at 7:39
1

Go into Excel's own options and set the locale there.

This may seem crazy but Microsoft coded the Office installer to be entirely independent of locale and language installed on your Windows.

I've tried every possible workaround and asked around Microsoft tech support but the suprizing truth is if you have, say, an Office suite purchased in France but you speak English and your Windows is in English it will install French regardless and you'll have to set the locale for your files manually and if you want another language for the menus you'll have to download and install a language pack wich cannot install on an upgraded office suite with, say ... publisher. fun tid-bit.

Running it via wine the issue is obviously still present and that's the only way to do it.

hope this helps.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.