0

I have a laptop with Windows 7 installed and I installed Ubuntu on an external USB hard drive. The idea was to connect the USB drive and turn on the computer whenever I need the Ubuntu environment, but something went wrong with the installation.

Since the installation, I can't use my Windows 7 environment without connecting the external drive first, and choose Windows in the GRUB table (like using cables to start a car every time I wish to drive).

When I start my laptop without the external drive connected, I get this message:

error: no such device: {device id}.
Entering rescue mode...
grub rescue>

I already checked my BIOS configuration, and the primary drive is my internal drive, where Windows is installed.

Any ideas how to fix this?

Thanks!

marked as duplicate by Charles Green, Eric Carvalho, Ravexina, user364819, David Foerster May 7 '17 at 14:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    When in Ubuntu, install grub to external drive probably sdb (check first) 'sudo grub-install /dev/sdb` Then use your Windows repair disk to restore the Windows boot loader to internal drive. And set BIOS to boot external drive first, internal second. Then when external not found it boots internal drive.help.ubuntu.com/community/RestoreUbuntu/XP/Vista/7Bootloader When installing Ubuntu to external drive always use Something Else as that is only install option that lets you choose to install grub boot loader to external drive. (only works with BIOS installs currently). – oldfred May 5 '17 at 17:12
  • Just an idea... install VM Player or Virtualbox in Windows and install Ubuntu as a VM, storing it on the external disk. Obviously you need to un-install the GRUB loader first. – user680858 May 5 '17 at 23:42
  • The linked questions only deal with Ubuntu's side of the issue. You'll need to fix the boot loader for Windows on the internal drive which is off topic here on Ask Ubuntu. However you're welcome to ask that on Super User. – David Foerster May 7 '17 at 14:18