The login screen was fine on first boot with Nouveau but when I installed nvidia-381 from the graphics-drivers ppa and rebooted my login resolution is extremely high making the font and ui really small. I can still login just fine but it's an eyesore and I'd like to get it fixed.

In my searching for an answer I found a solution of setting my resolution through system settings and copying the monitors.xml file from my ~/.config folder to /var/lib/gdm3/.config but obviously that didn't work.

  • Ubuntu Gnome 17.04

  • Nvidia 381.09 w/ nomodeset (It won't display the login screen otherwise.) I've also tried 378.13 and it didn't work either.

  • Screen res 1360x768


Recent update fixed the issue for me!

Start-Date: 2017-05-29 20:35:51

Commandline: apt upgrade

Requested-By: cxf (1000)

Upgrade: gnome-settings-daemon-schemas:amd64 (3.24.1-0ubuntu1, 3.24.2-0ubuntu0.1), gnome-settings-daemon:amd64 (3.24.1-0ubuntu1, 3.24.2-0ubuntu0.1)

End-Date: 2017-05-29 20:36:23

  • I upgraded from 16.10 to 17.04 but in my case the login screen has lower resolution and everything is larger than normal. All results I found about this are outdated, would also want to know how to easily fix the resolution of gdm3.
    – Sir_FZ
    May 6, 2017 at 12:21

3 Answers 3


I figured this one out! I have an Asus Q534UX with a 4k display. I noticed that my screen resolution was set to 4k, but I had my scaling set to 2 which makes the desktop usable while still in high resolution.

Once choice is to set the screen resolution to something other than 4k, but that isn't ideal especially when it's not your displays native resolution.

The answer is to do as you've said, copy the monitor.xml file to /var/lib/gdm3/.config, i.e.

sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config/

Next, edit it so you change the resolution to something more reasonable in the login screen. I changed mine to 2560x1440 but that may be still a bit high. It is MUCH better.

You're only in the login screen for a bit, then when the desktop comes up the resolution and scaling goes to normal.

Save your edits and reboot to see the changes.

  • Set it to 1280x720 and 800x600 but it still doesn't work. It doesn't scale the UI just the resolution. Pastebin May 13, 2017 at 8:18
  • This solution allows a Ubuntu 20.04 user to change the resolution of their Ubuntu 20.04 login screen. I write this because most new user do not know gdm3 powers the Ubuntu 20.04 login screen. I tried this solution and it works.
    – Sun Bear
    Apr 28, 2021 at 20:53
  • After copying monitors.xml to /var/lib/gdm3/.config/, you need to run "sudo dpkg-reconfigure gdm3"
    – gkso
    Aug 5, 2021 at 5:39

For Ubuntu 20.04, not only did I have to create a copy of the monitors.xml file as described in other answers, but I also had to disable Wayland at the login screen. To do this, I ran sudo nano /etc/gdm3/custom.conf, and then uncommented the line WaylandEnable=false. This forces gdm3 to use Xorg at the login screen. Restarting gdm3 with sudo systemctl restart gdm3 (which also killed my current login session) brought me back to the login screen with the expected monitor resolution.

  • This was it. In VirtualBox running Ubuntu 20.04, the login screen resolution just wouldn't change at all. WaylandEnable=false is what did the trick.
    – Mendhak
    Nov 13, 2021 at 23:14

It worked also for me.

sudo cp ~/.config/monitors.xml /var/lib/gdm3/.config/

To generate ~/.config/monitors.xml I had to attache an external monitor to laptop. Then boot up, and when the login screen was shown I closed the lid. Then the login screen moved to the external monitor and I could login. Then run 'Settings', open the lid again and adjust the display on the internal monitor. Then the ~/.config/monitors.xml is created and can be copied.

Mind the "s" at the end of "monitors"!

  • 3
    Is this solution Ubuntu 17 specific? I tried in Ubuntu 20.04 without success :( Oct 15, 2020 at 13:36
  • 2
    What @JoseCarlosM.Garcia-Vaso says is correct, copying monitors.xml from user home to /var/lib/ folder does not resolve the problem in Ubuntu 20.04. It works in Ubuntu 18.04. though.
    – OpenITeX
    Dec 14, 2020 at 2:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.