0

This question already has an answer here:

To be honest, I'm new to Ubuntu and 've heard that this OS more advanced rather than Windows. But why the installation of the simple browser became so complicated is out of my mind. So I downloaded google-chrome-stable_current_amd64.deb. After running sudo apt-get install google-chrome-stable_current_amd64.deb and after running sudo apt-get install google-chrome-stable_current_amd64 and after running sudo apt-get install google-chrome-stable in the terminal nothing happens, but the message Couldn't find any package by glob and Couldn't find any package by regex. Trying to install it normally through UI brings Ubuntu Software window to a frozen state. Has anything might be done to install the browser on the Ubuntu? Tried to navigate to Downloads folder where my google-chrome-stable_current_amd64.deb is located and run sudo apt install command - didn't work. Terminal shows Unable to locate package google-chrome-stable_current_amd64.deb Thanks.

marked as duplicate by Geppettvs D'Constanzo, Ravexina, Byte Commander, Organic Marble, George Udosen May 4 '17 at 21:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What's wrong with good old double click on the file ? – runlevel0 Jul 31 '17 at 18:05
11

Google chrome is not available in Ubuntu official software repositories, you can install chromium instead of Google chrome.

to install chromium run:

sudo apt install chromium-browser

And to install Google chrome, you should download its deb installer from here. which you already did.

then to install it run:

sudo dpkg -i google-chrome-stable_current_amd64.deb

If you encounter to any errors related to dependencies; run:

sudo apt install google-chrome-stable_current_amd64.deb
  • The terminal says E: Unable to locate package gdebi. This might be some sort of configuration problem – President May 4 '17 at 20:53
  • 1
    In 16.04 and later, you can use apt to resolve dependencies without the extra step of installing gdebi: sudo apt install /path/to/google-chrome-stable_current_amd64.deb – user535733 May 4 '17 at 21:05
  • @President are your source updated? I updated my answer ;) – Ravexina May 4 '17 at 21:30
  • @user535733 Cool, Didn't know about it... thanks. updated the answer ;) – Ravexina May 4 '17 at 21:30
  • 1
    @Egrimo You'll be surprised but I started to read other posts on google / stackoverflow, and somehow I did installation of the google chrome. Seems like I was missing some dependencies, I run several commands in the terminal to update (still, I'm so new to Ubuntu that I don't even know what was updated :-). After update happens I noticed that google chrome installed normally with the $sudo apt install google-chrome-stable_current_amd64.deb – President May 5 '17 at 13:55
2

That is because .deb files are installed with a different command!

In order to install a package from a .deb file you should use the following command: sudo dpkg -i google-chrome-stable_current_amd64.deb in your case.

As I remember it, that's all installing chrome requires, that said, as a general fyi sometimes dpkg will not work the first time and it will inform you to run sudo apt-get install -f. But after you do just that, you will be able to run dpkg -i again and it will work.

  • Well, the problem that terminal displays is "cannot access archive: No such file or directory." Do I need to provide some sort of full path to the .deb file? Like in windows with slashes? Not pretty familiar with Ubuntu – President May 4 '17 at 20:56
  • @President, yes you must provide the path to the package. The package manager is not psychic. – user535733 May 4 '17 at 21:06
  • @user535733 After giving a full path to the google-chrome-stable_current_amd64.deb there is another error message appears in the terminal "dpkg: error processing package google-chrome-stable (--install): dependency problems - leaving unconfigured Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ... Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ... Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ... Rebuilding /usr/share/applications/bamf-2.index... Errors were encountered while processing: google-chrome-stable" – President May 4 '17 at 21:18
  • You downloaded a deb package that is incompatible with your release of Ubuntu. Don't do that. Delete the incompatible package, then read askubuntu.com/questions/510056 – user535733 May 4 '17 at 21:22
  • @user535733 So there is a place where I can actually pick up the correct release of the Chrome for my Ubuntu. I'm running Ubuntu 16.04 LTS – President May 4 '17 at 21:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.