Until a few days ago I had a fine working dual boot with Ubuntu 16.10 and Windows 10, using Grub2. Then Windows decided it needed to perform some updates. After the update, my system booted directly into Windows, skipping Grub. So in order to get back into my Ubuntu system, I created a Boot-Repair USB, and used the default repair option in there. After that, I got my Grub back, and can boot into Ubuntu again. However, now I cannot boot into Windows anymore. If I select the Windows option in Grub, I immediately get an error "cannot load image".

I also tried changing the boot order, to load the Windows Boot Loader first. Then I end up with an error "Failed to open \EFI\BOOT\grubx64.efi Not found"

Some things I tried, based on my googling:

  • run boot repair again -> Makes no difference
  • Disable secure boot in system setup -> Makes no difference
  • Use the Startup Repair option from Windows restore partition -> Gives an error that it cannot repair the startup
  • use rEfind bootloader -> Recognizes Windows, but cannot boot it either

Boot repair info located here: https://pastebin.com/0mPR4bwf

Anyone have any suggestions on what I can try next to be able to boot into Windows again?


4 Answers 4


I see this question was asked a couple of years ago. Since it comes up fairly high in the search results, I'll put in a late answer anyway. I have a dual-boot Windows/Ubuntu machine that I've been using since Win10 came out. Every major Windows update kills the dual-boot.

When this happens, open a Windows "command prompt" as Administrator. Then enter the following command:

bcdedit /set "{bootmgr}" path \EFI\ubuntu\shimx64.efi

For me, this has reliably fixed the problem every time. Obviously, for other distros, the path may be different. This article provides some good background information.

  • Really thanks a lot for putting in this answer; it seems to be "the right" approach. The background article is nice, but I think the bcdedit reference should also be linked here, and unfortunately it doesn't go into the path variable much. Which file system will this path be located/searched in?! is it a path known to Windows, which Windows 10 will go and configure somewhere in the BIOS, or a path that the BIOS (UEFI) would locate through its own device configuration?
    – matanster
    Aug 2, 2019 at 19:13
  • 1
    You're welcome! Unfortunately, I don't have any more information. I only use Windows on rare occasions, so I haven't looked into the technical details. Aug 7, 2019 at 6:46
  • Just went trough this issue again with a Windows10 update breaking the Ubuntu 20 boot, the answer that @BradRichards provided is correct. Can also fix with this: 1.Get a bootable Ubuntu USB stick 2. Restart the machine and press F12 to see the boot menu. Select "Ubuntu". 3. In the menu, select "Try ubuntu without installing" 4. Connect to your WiFi. Download and run boot-repair using the following commands: sudo add-apt-repository ppa:yannubuntu/boot-repair sudo apt-get update sudo apt-get install -y boot-repair && boot-repair Restart the machine, the issue should be fixed. Nov 22, 2020 at 15:25

My solution has been different. And, please, do not reinstall Windows or do some other drastic stuff of the same kind! If you have a dual boot, you are likely to have at least four partitions: NTFS System Reserved, Main Windows NTFS, Linux Swap, Linux Ext4 (I am using SysLinux, but if you prefer Grub and alike you may also have a Linux Boot Partition). Normally the Linux Ext4 (or Linux Boot) partition would have a boot flag set. All you need to do is set boot flag to the Windows System Reserved partition, install updates and then change the boot flag back (after windows has restarted and installed its updates fully). I always have a live CD/USB handy (Knoppix or antiX), so I can boot from it, open gparted and change partitions boot flag around at will...


Faced the same issue a few months back. On inspection Windows 10 actually deleted the Ubuntu partition from the drive.

I decided to move that Laptop exclusively to Ubuntu to prevent such issues in the future. Windows 10 updates are just out of control.

I could not get either OS running after this either. Seems like it's fatally broken. I pulled the drive for later analysis.

In your case you will probably have to reinstall Windows and restore a fresh backup.AKA Windows 10 broke it.


There's a bunch of threads on this. Another one worked.

F2 to get to bios. Disabled Smart Boot again Move Ubuntu above windows for priority. Save and exit.

Worked for me on Acer Apire 5 A515-43.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .