40

I am using an Acer Aspire 3680 with Intel GMA 950 video running Ubuntu 16 and I cannot find the command to adjust the screen contrast setting. Too many colors and grays are washed out on the current setting.

What command or graphical utility will do this?

3
  • @Videonauth This question is a year older.
    – CyberSkull
    Dec 2, 2017 at 12:09
  • and you hadn't had the chance to pick a correct answer for your problem to accept?
    – Videonauth
    Dec 2, 2017 at 12:12
  • Nothing had worked so far on that model. I don’t have regular access to the machine to check anymore.
    – CyberSkull
    Dec 2, 2017 at 12:16

5 Answers 5

45

On command line (Terminal), try writing

xgamma -gamma 0.3

You should see a very noticeable difference. Experiment with different values. 1.0 is normal value. Setting a lower gamma will increase the contrast of bright values (decrease white washing), and setting a higher gamma will increase the contrast of dark values (but increase white washing).

1
  • Gamma is not contrast
    – ASWIN VENU
    Feb 11, 2021 at 14:40
19

maybe you can try "xcalib".

sudo apt-get install xcalib

default(clear):

xcalib -c

Load ICC file:

xcalib ICC_file.icc

adjust contrast:

xcalib -co 70 -a

PS. number means percentage, -a means alter if you want to adjust more, ask "man"! lol

man xcalib

hope that is helpful!!

6
  • Where are the icc profiles kept?
    – CyberSkull
    Jan 11, 2012 at 8:18
  • Ah, found some in /usr/share/color/icc.
    – CyberSkull
    Jan 11, 2012 at 8:20
  • Well, it does something, but it is not fixing the contrast issues.
    – CyberSkull
    Jan 11, 2012 at 8:31
  • This works only for current session. When I restart again it doesnot work
    – user43941
    Jan 28, 2012 at 13:47
  • I installed xcalib and it seems to only decrease contrast: "xcalib -co 80 -a" decreased it, "xcalib -co 100 -a" left it unchanged, "xcalib -co 90 -a" decreased it some more... It seems multiplicative rather than on an absolute scale, but trying numbers >100 gives an error. Help? How can I get my original contrast back?
    – weronika
    Apr 24, 2017 at 0:01
4

I have written a gui front-end for xcalib, which can be found on https://github.com/Ablinne/kolorcontrol.

It provides sliders for brightness/color and gamma for red/green and blue channels respectively. It will display the commands for an autostart script.

0
4

I had no luck with xgamma, compizconfig-settings-manager or xcalib.

In the end, I was able to use xrandr to successfully change my screen's contrast (and other settings).

This was on an MSI laptop with an Nvidia Geforce GTX graphics card.


To install:

sudo apt-get update
sudo apt-get install x11-xserver-utils

First run xrandr to see the available screens. eDP-1-1 is the only connected screen in my case. Then run xrandr --output <your screen> --gamma r:g:b

See below for my terminal's output.

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.01*+  59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   ...
   ...
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  

$ xrandr --output eDP-1-1 --gamma 0.8:0.8:0.8
-2

Enabling the setting for creating Negative screen contrast may help you. Here is the link-

How do I change screen contrast?

3
  • 1
    That is… not useful in my situation.
    – CyberSkull
    Apr 5, 2013 at 9:51
  • Sorry. There are 2 ways to adjust contrast 1) On the physical monitor settings 2) With the graphics card software settings. Here is a link with similar issue, hopefully it help: superuser.com/questions/96539/…
    – Sepero
    Apr 5, 2013 at 12:06
  • If a link to another answer on Ask Ubuntu contains the answer you would be better of flagging the question as a duplicate
    – Videonauth
    Dec 2, 2017 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.