When I press Ctrl+Alt+T the Terminal opens after around 30 seconds. That's pretty annoying. If I open it with Alt+F2 and enter gnome-terminal the window appears instantly as usual.

I'm using Ubuntu 16.04 with gnome3.

Thank you for your help in advance!

  • Maybe look in System Settings -> Keyboard -> Shortcuts -> Launchers -> Launch Terminal, and check that it's set correctly. Have you made any changes to your keyboard shortcuts recently?
    – wjandrea
    May 4 '17 at 19:28
  • It's set correctly and I haven't done any canges. May 4 '17 at 20:36
  • 2
    @AlexLeidwein, There is now a solution available versus just a workaround. Remove dbus-user-session which is not installed by default in Ubuntu 16.04. Jul 24 '17 at 10:15
  • 1
    Possible duplicate of Gnome keyring daemon not starting up properly
    – Byte Commander
    Aug 4 '17 at 12:41

Temporary workaround discussed in comment 16

run gnome-keyring-daemon in terminal with no command line options.
Then everything works as normal after entering password to unlock keyring.

On my system I have to open HUD before the password prompt shows up. If I open the HUD before the terminal command, the password prompt dialog shows immediately.

Output of journalctl -f shows
gnome-keyring-daemon[12913]: Gkm: using old keyring directory: ...

Now Solved:
For me and many others the solution to this issue has been to remove dbus-user-session which was added along with a recent install of software that is not needed. For me, it was added when I installed flatpak


  1. sudo apt-get remove --purge dbus-user-session
  2. Reboot

More context is available starting at comment #67 in this thread.

  • 3
    This should be the top voted and accepted answer as it contains a real fix and not just a dirty workaround of killing the gnome-keyring-daemon, which will make the saved passwords etc. unavailable IIRC.
    – Byte Commander
    Aug 4 '17 at 12:42
  • This worked perfectly! Also fixed too similar problems I had: delay between pressing "Print Screen" and the screenshot being taken, and Google Chrome being slow to first launch.
    – Alex
    Jun 29 '18 at 14:08
  • Ran into this after deliberately installing dbus-user-session in order to support systemd services that raise notifiers over dbus. This is presumably some misconfiguration where the systemd user session isn't actually the same as the GUI session.
    – Adrian
    Jul 17 '18 at 16:05

Based on this answer on superuser:

From the bug filed by xgdgsc, this slow response to GNOME shortcuts appears to be caused by gnome-keyring-daemon. In particular, having multiple instances of the daemon appears to cause shortcut execution to pause while attempting to communicate with the daemon until it times out. You can use the following command to check if you have multiple instances of the daemon running:

pgrep gnome-keyring --list-full

On CentOS 7 with GNOME 3.14.2, I was able to work around this by killing both processes:

killall gnome-keyring-daemon

gnome-keyring-daemon automatically restarted with only one instance when I next used a GNOME keyboard shortcut, and the shortcut executed instantaneously.

  • Even with only one gnome-keyring running, I'm still getting slow response when opening terminals. When I killed all gnome-keyring-daemon Chrome was not able to login. May 17 '17 at 23:25
  • @AntoniosHadjigeorgalis on my experience, this type of delay happening just for one or two shortcuts. If killall gnome-keyring-daemon not working for you, maybe reassigning those shortcuts can help.
    – ICE
    May 18 '17 at 10:22
  • @ICE new shortcuts did not work either. May 18 '17 at 21:19

Open Startup Application and add new

  1. Add new
  2. Name : whatever
  3. Command : killall gnome-keyring-daemon
  4. Comment : whatever


  • 3
    What does terserah supposed to mean?
    – Anwar
    May 18 '17 at 17:29
  • 2
    @Anwar: "terserah" is an Indonesian/Malay word for "whatever" or "anything". The name and description of start up application is only there to help you find and organize it, but it doesn't really matter what you put in there. Maybe SierraX copied it from some blog/site somewhere and forget to translate it?
    – Lie Ryan
    May 20 '17 at 5:18

Actually this helped me. Went to System Settings -> Keyboard -> Shortcuts -> Launchers -> Launch Terminal there was written something new accelerator. I reset the key by hold pressing Ctrl + Alt + T again. it solved the problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.