0

My brightness used to work normally until I did bunch of things I don't know which caused the problem. The brightness from keyboard shows me the indicator on screen but doesn't change, from settings doesn't change either.

What I did before I had the problem was :

First, I updated my system.

Second, I ran:

rm -rfv dontDeleteMe && mkdir dontDeleteMe

then:

rm -rf dontDeleteMe && mkdir dontDeleteMe

hoping to reverse it.

Then tried this answer to repair a tty problem.

Output of sudo lspci -v -s 00:02.0

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    DeviceName: 32
    Subsystem: Hewlett-Packard Company Core Processor Integrated Graphics Controller
    Flags: bus master, fast devsel, latency 0, IRQ 30
    Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 4050 [size=8]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [a4] PCI Advanced Features
    Kernel driver in use: i915
    Kernel modules: i915

Output of sudo lshw -class display

  *-display               
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:30 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:4050(size=8) memory:c0000-dffff

Now, What did I do to cause my problem and how can I reverse it?

8

Browse other questions tagged or ask your own question.