3

I'm new to ubuntu and I'm getting very frustrated so far. I'm trying to get chrome to work properly, as I have a chromecast I would like to use, as well as all the extensions I have on chrome.

I've tried to install it any way possible and tried to install chromium as well. Every time I install it, it shows that it's opened but I cannot see the window. I've tried reinstalling chrome, chromium and ubuntu several times without any luck.

I haven't found a solution online and if I can't find one soon, I'll probably just go back to windows.

I'm running ubuntu 17.04

what I've tried so far?

google-chrome

shows no output but puts an icon in the launcher, but chrome window doesn't appear. same is with chromium

I think it may be a permissions issue. Nothing is being written to .config folder. Checked hidden files and no folders for chrome or chromium. Any ideas on what is causing this?

  • how did you try to install it? if you add little bit more details, we'll be more than happy to help you – Sumeet Deshmukh May 4 '17 at 16:47
  • I tried installing deb file from their website. I also tried to install it through the terminal. I installed chromium through software center – rob chiarello May 4 '17 at 16:57
  • and can you update your question with the output of google-chrome ? – Sumeet Deshmukh May 4 '17 at 16:59
  • I'm sorry. I'm not sure what you mean. – rob chiarello May 4 '17 at 17:00
  • google-chrome this is the command used to launch Google chrome browser using CLI (command line interface) all you have to do is open up your terminal and paste google-chrome and post the output that you get here – Sumeet Deshmukh May 4 '17 at 17:04
6

Let try this.. Go to system setting -> Select display setting Check whether how many displays are enabled. If enabled more than one then turn off the unused display or enable mirror option. This can solve your issue.

| improve this answer | |
  • This might work, but would be better off as a comment asking the OP if he is using Ann external display. – fosslinux Jul 20 '17 at 5:09
  • 1
    Actually this answer worked for me even though I am not using an external display. I am running ubuntu 16 on a macbook pro and enabling mirroring forced the invisible chrome windows to re-appear. – snow6oy Jan 4 '18 at 11:48
  • This does not work. – Green Mar 31 '18 at 16:42
  • 1
    Awesome. This solved it for me! – guillefix May 2 '18 at 12:44
  • 1
    This worked for me. I actually have two monitors, but the second was not powered on. After I powered on the second monitor the Chrome browser was there. This might sound logical, but as I usually need the second monitor only for one specific application, I never expected Chrome to be there. – Peter Gloor Nov 1 '19 at 16:44
1

Try opening Chrome with the --no-sandbox switch.

I managed to get Chrome 59 running using that switch, but since it's deprecated it pops up a warning. I've rolled back to Chrome 58 for now.

| improve this answer | |
-1

First get a terminal and type sudo install gdebi Enter your password and type "y" when prompted Run Firefox and google "chrome" Save "deb 64" Open using gdebi It will work perfectly

| improve this answer | |
  • Already tried that. Did not work. Seems as though chrome opens, I just can't view the window – rob chiarello May 4 '17 at 18:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.