18

I am on Ubuntu 16.04.2 and today Google Chrome and Chromium started taking a long time to load. Once opened, they freeze frequently.

I loaded Chrome from the command line and got this message:

$ google-chrome
Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[8032:8100:0504/165233.258127:ERROR:connection.cc(1954)] Cookie sqlite error 5, errno 0: database is locked, sql: DELETE FROM cookies WHERE persistent != 1
[8032:8070:0504/165235.449471:ERROR:leveldb_database.cc(311)] Failed to open LevelDB database from /home/fd/.config/google-chrome/Default/IndexedDB/https_www.google.pt_0.indexeddb.leveldb,IO error: /home/fd/.config/google-chrome/Default/IndexedDB/https_www.google.pt_0.indexeddb.leveldb/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)
[8032:8070:0504/165235.450323:ERROR:indexed_db_backing_store.cc(1403)] Unable to open backing store, not trying to recover - IO error: /home/fd/.config/google-chrome/Default/IndexedDB/https_www.google.pt_0.indexeddb.leveldb/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)
Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[8032:8074:0504/165337.922687:ERROR:connection.cc(1954)] Cookie sqlite error 5, errno 0: database is locked, sql: COMMIT

Loading chromium from the command line returns this:

$ chromium-browser
Gkr-Message: secret service operation failed: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Killed

I already completely removed chrome/chromium, deleted their respective folders in .config and .cache

How can I fix this?

10

Solved this by creating this file ~/.config/autostart/gnome-keyring-daemon.desktop with the following content:

[Desktop Entry]
Type=Application
Exec=/usr/bin/gnome-keyring-daemon
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_US]=Gnome Keyring Daemon
Name=Gnome Keyring Daemon
Comment[en_US]=Load gnome keyring daemon
Comment=Load gnome keyring daemon

Then I rebooted and Chrome/Chromium went back to normal (source).

After rebooting I kept getting this message "keyring was not unlocked upon signin" and had to type my password. I got rid of it by following How can I stop being prompted to unlock the 'default' keyring on boot?

  • Did this give you some "keyring was not unlocked upon signin" message and prompt for the user-password? – MrMesees May 6 '17 at 21:20
  • 1
    Yes. I got rid of it by following these instructions:askubuntu.com/questions/867/… – Filipe Dias May 7 '17 at 16:01
  • 1
    Clearing the keyring password cannot be an acceptable solution nor workaround – Laurent May 12 '17 at 23:58
  • 2
    Actually this answer helped fix the issue cleanly – Anwar May 22 '17 at 14:07
  • Starting gnome-keyring-daemon solving my worse symptom on a TigerVNC :1 of Debian Jessie: Chrome wouldn't start at all, even after allegedly timing out libsecret and "GNOME keyring" and reverting to "basic (unencrypted) store for password storage", per --enable-logging=stderr. – Martin Dorey Jun 30 '18 at 17:17

protected by Community May 19 '17 at 14:03

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.