0

Since upgrading to 16.04, when I try to install or update a software installation in "Ubuntu Software" the password for my default admin account is not recognized/accepted. I know that the password is correct, because I can su into the account with the same password. Apparently I am not alone in this problem. I found these related threads:

but do not find the answers there helpful. In fact, only the second thread has anything I would call an answer. However, although I can handle the command-line interface if need be, I am not well-versed in Ubuntu, and have trouble finding the applications to update without the "Ubuntu Software" center. Since my failed attempts, all I see in its "Installed" and "Updates" tabs are the rotating "wait" symbols. I tried the second approach mentioned, starting "software-center" from a terminal window. The application which then starts (after producing a number of error messages in the terminal window) has the same icon as the "Ubuntu Software" which starts from my quick launch toolbar, but the GUI looks different. It too shows nothing but a rotating "wait" symbol, but I can at least identify it via "Help - About" as "Ubuntu Software Center" 15.12. The original "Ubuntu Software" from my quick launch bar has no menus which would allow me to identify it.

  • Today, after rebooting, "Ubuntu Software" (the one from my quick launch bar) appeared to accept my password. It now appears to have installed the new application that I tried to install yesterday and shows only "OS Updates" instead of the list of around 10 pending updates it showed yesterday. When I click "Install" (either the button above the list or the one next to "OS Updates", it looks as though it is installing, i.e. the progress bar moves from left to right. However, when it is done, "OS Updates" still appears in the "Updates" list, event after refreshing. Any suggestions? – R B May 5 '17 at 8:43
  • Today, "Ubuntu Software" (the one from my quick launch bar) showed 3 Updates on launching: "OS Updates", "Firefox"& "Security & Privacy". I clicked "Install" by "OS Updates". The progress bar slowly showed completion, but at the end, no change was apparent. I then clicked directly on "Security & Privacy", in order to find out what I would be updating. A new dialog opened with text to the effect of "Downloading new change description". and remained open for as long as I cared to wait (about 5 minutes) without showing an signs of change or progress. (to be continued) – R B May 16 '17 at 14:32
  • In order to update Firefox, I closed it, and then closed the info window from "Security & Privacy". At this point, both of these items disappeared from the "Updates" list in "Ubuntu Software". What is going on? Is this the way this is intended to function? – R B May 16 '17 at 14:32
  • Since I can't get Ubuntu Software to work properly in 16.04 and get no error messages which might help diagnose the problem, I have given up and am happily using synaptic. It seems to work fine if I start it from a privileged terminal window using the same credentials which I was using in Ubuntu Software. – R B Jun 15 '17 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.