-1

Okay, so my ultimate goal is to install my Epson WF-2630 AIO printer. Upon trying to do this, I found that trying to install any package w/apt causes the same dependency error:

jen@DotySupreme:~/Downloads$ sudo dpkg -i epson-inkjet-printer-escpr_1.4.1-1lsb3.2_amd64.deb
(Reading database ... 223896 files and directories currently installed.)
Preparing to unpack epson-inkjet-printer-escpr_1.4.1-1lsb3.2_amd64.deb ...
Unpacking epson-inkjet-printer-escpr (1.4.1-1lsb3.2) over (1.4.1-1lsb3.2) ...
dpkg: dependency problems prevent configuration of epson-inkjet-printer-escpr:
 epson-inkjet-printer-escpr depends on lsb (>= 3.2); however:
  Package lsb is not configured yet.

dpkg: error processing package epson-inkjet-printer-escpr (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Errors were encountered while processing:
 epson-inkjet-printer-escpr

So I tried following instructions from several posts:

  1. apt-get install can't install any software

    • After reading this one, I think my error might be because I once ran autoremove, but I don't know how to shut it off.
  2. Apt-get fails to install any software since latest update

    • I don't think this one will help, because I don't have a process to kill.
  3. Errors when trying to install
    • The comment "@tlo I fixed it myself somr kind og command that's turns the terminal purpel and it say yes or no I choose yes and boom it fixed everything sudo dpkg -configue -a then sudo apt-get update" says that he answered his own question, but doesn't give me enough information to know what he did.
  4. How to install Epson printer drivers on Ubuntu 16.04?
    • I added the trusty sources, but it doesn't add the printer, and when I manually select either the .rpm or .deb, I get a list of dot matrix printers to choose from.

When I try to use the gui to install the printer, and tell it to download the drivers itself, it just sits there frozen.


I've run several commands:

jen@DotySupreme:~$ sudo apt-get install printer-driver-escpr
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgcc1:i386 : Depends: libc6:i386 (>= 2.2.4) but it is not going to be installed
 lsb-core : Depends: libc6:i386 or
                     libc6-i386 but it is not going to be installed
 zlib1g:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be installed
N: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

jen@DotySupreme:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  libc6:i386
Suggested packages:
  glibc-doc:i386 locales:i386
The following NEW packages will be installed:
  libc6:i386
0 upgraded, 1 newly installed, 0 to remove and 57 not upgraded.
7 not fully installed or removed.
Need to get 0 B/2,275 kB of archives.
After this operation, 9,811 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
(Reading database ... 223896 files and directories currently installed.)
Preparing to unpack .../libc6_2.23-0ubuntu7_i386.deb ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing archive /var/cache/apt/archives/libc6_2.23-0ubuntu7_i386.deb (--unpack):
 subprocess new pre-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.23-0ubuntu7_i386.deb
N: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Sub-process /usr/bin/dpkg returned an error code (1)

jen@DotySupreme:~$ sudo apt-get update
Reading package lists... Done
N: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/lib/apt/lists/

jen@DotySupreme:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of zlib1g:i386:
 zlib1g:i386 depends on libc6 (>= 2.4); however:
  Package libc6:i386 is not installed.

dpkg: error processing package zlib1g:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lsb-core:
 lsb-core depends on libc6:i386 | libc6-i386; however:
  Package libc6:i386 is not installed.
  Package libc6-i386 is not installed.
 lsb-core depends on zlib1g:i386 | lib32z1; however:
  Package zlib1g:i386 is not configured yet.
  Package lib32z1 is not installed.

dpkg: error processing package lsb-core (--configure):
 dependency problems - leaving unconfigured
Setting up cups (2.1.3-4) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package cups (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of lsb:
 lsb depends on lsb-core (>= 9.20160110ubuntu0.2); however:
  Package lsb-core is not configured yet.

dpkg: error processing package lsb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgcc1:i386:
 libgcc1:i386 depends on libc6 (>= 2.2.4); however:
  Package libc6:i386 is not installed.

dpkg: error processing package libgcc1:i386 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of epson-inkjet-printer-escpr:
 epson-inkjet-printer-escpr depends on lsb (>= 3.2); however:
  Package lsb is not configured yet.

dpkg: error processing package epson-inkjet-printer-escpr (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lsb-printing:
 lsb-printing depends on lsb-core (>= 9.20160110ubuntu0.2); however:
  Package lsb-core is not configured yet.

dpkg: error processing package lsb-printing (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 zlib1g:i386
 lsb-core
 cups
 lsb
 libgcc1:i386
 epson-inkjet-printer-escpr
 lsb-printing

jen@DotySupreme:~$ sudo apt-get clean
N: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/lib/apt/lists/

UPDATE, tried to install synaptic:

jen@DotySupreme:~$ sudo apt install synaptic
[sudo] password for jen: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
synaptic is already the newest version (0.83).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgcc1:i386 : Depends: libc6:i386 (>= 2.2.4) but it is not going to be installed
 lsb-core : Depends: libc6:i386 or
                     libc6-i386 but it is not going to be installed
 zlib1g:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be installed
N: Ignoring file '20auto-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
0

you are using epson-inkjet-printer-escpr_1.4.1-1lsb3.2_amd64.deb and the Epson website lists the epson-inkjet-printer-escpr_1.6.13-1lsb3.2_amd64.deb as the version they recommend http://download.ebz.epson.net/dsc/du/02/DriverDownloadInfo.do?LG2=EN&CN2=&DSCMI=55539&DSCCHK=5ef6ec128765534a989152269045f12fc58077f2 .so if you download and save that .for a new search,I start here http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX and enter the printer number.

I see various error messages "ibc6:i386 is not installed"; and "Package lsb-core is not configured yet" please check lsb installed; ideally using synaptic which one can install with sudo apt install synapticand if lsb is installed I would try again in a terminal with sudo apt install epson-inkjet-printer-escpr_1.6.13-1lsb3.2_amd64.deb

new terminology I understand is to just use apt install

  • Thank you for the correct file, I didn't notice the discrepancy. However, I still get dependency problems when using apt. I updated my question to include the results of trying to install synaptic. – Keiva May 2 '17 at 23:47
  • the apt script says "E: Unmet dependencies. Try 'apt-get -f install' with no packages"so do try that; "sudo apt-get -f install"here is a link to a thread and read post #7 as the original poster sorted his issues in that forums.linuxmint.com/viewtopic.php?f=51&t=242497 – pdc May 3 '17 at 2:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.