6

I have an Intel NUC7i5BNK, which is a Kaby Lake NUC (i5-7260u) with HDMI 2.0 supporting 4K/60Hz output. I installed a fresh copy of Ubuntu 17.04 on it, but I can only output 4K/30Hz to my TV. I'm a relatively inexperienced user, I don't see any settings for refresh rate in the display settings.

My intention for this NUC is to use it as an HTPC so 4K/60Hz output is pretty important to me. How can I enable it?

5 Answers 5

4

Nick's post was a real help in leading me this this solution:

xrandr --newmode "3840x2160x60.00"  533.250000  3840 3888 3920 4000  2160 2163 2167 2222  +HSync -VSync
xrandr --addmode DP-1 "3840x2160x60.00"
xrandr --output DP-1 --mode 3840x2160x60.00

This 7i5 NUC now displays UHD on a Samsung TV (UN40MU6300).

Four+ hours I've spent figuring this out. Above working Modeline was finally found via the Universal Modeline Calculator in 'Reduced Blanking Timing' mode. I don't know the disadvantage, but it's now 60HZ and crystal clear. Ubuntu and the TV's 'info mode' both show 3840x2160/60Hz.

umc.exe 3840 2160 60 -rbt

Also 7th Gen NUC HDMI 2.0 firmware must be upgraded to an April 2018+ release (Sorry but the update tool only runs on Win10). Get a certified HDMI 2 cable too (trying an old cable just now made the image snowy).

Verification of resolution

Root cause is almost certainly Intel's on-chip Iris Plus Graphics 650 having a relatively low max pixel rate (533Mhz is in the working modeline, but cvt wanted 712Mhz)

3
  • Brief note: Even one a new hdmi 2 certified cable are giving slight snow sometimes. Twisted Veins hdmi cable brand appears to be the best of all I tried. Root cause is likely the hardware/ firmware though. Also this Samsung UHD TV has known incompatibility issues. Also at some point I'll try to find how Win10 does 4K with my screen as it's flawless. PowerStrip in Win10 does not show that actual settings, but there must be some way to discover the settings. Commented Jun 11, 2018 at 14:46
  • This modeline worked with a NUC6CAYH running Fedora 31 and a Samsung Q70R, but not with a Vizio M43-C1. Commented Dec 2, 2019 at 0:49
  • Get a certified HDMI 2 cable too (trying an old cable just now made the image snowy). - this might also discard this resolution. Commented Nov 26, 2021 at 0:34
3

I think I've got this figured out. It's now working for me at least. The secret is figuring out the correct modelines. What worked for my monitor might not work for a different monitor, but if the monitor supports 4k 60hz, then I suspect that the solution will be similar.

I searched until I rounded up a modeline that I thought might work for my monitor, and then I used xrandr to force the mode with the following steps:

  1. Add the new mode:

    xrandr --newmode "4096x2160_60" 556.730 4096 4104 4136 4176 2160 2208 2216 2222 +HSync -VSync
    
  2. Associate the new mode with your connected display. Could be DP-1, or DP-2, or maybe even HDMI. Just run xrandr by itself to see which display you're using, then add the mode:

    xrandr --addmode DP-2 4096x2160_60
    
  3. Tell your display to use the new mode that you've added:

    xrandr --output DP-2 --mode 4096x2160_60
    

I'm using the pluggable USBC to HDMI cable for my 4K TV, and the HDMI2 port goes to a 1080p monitor. Here's the cable I'm using: https://www.amazon.com/gp/product/B0727QQLV2

Ubuntu 17.04 on my NUC7i5BNH is now working exactly as I hoped it would.

1
  • In general, use cvt <witdht> <height> <hz> to generate the mode line. For example, cvt 3840 1600 60.
    – Raphael
    Commented Sep 5, 2019 at 8:57
1

What CPU? Most of Intel's iGPUs are limited to 4k @ 30Hz over HDMI (lame, I know). You'll more than likely have to get a display port -> HDMI adapter. Make sure it's one that supports 4k @ 60Hz; there's only a couple out there right now.

Here's a Display Port -> HDMI adapter on Amazon that has decent reviews and supports 4k @ 60Hz

Example: I7-7700T only supports 4k @ 60Hz over Display Port; it's limited to 24Hz through HDMI

Max Resolution (HDMI 1.4)‡
4096x2304@24Hz

Max Resolution (DP)‡
4096x2304@60Hz

Max Resolution (eDP - Integrated Flat Panel)‡
4096x2304@60Hz
0

Kaby Lake processors only support up to HDMI 1.4, which will be about 24 Hertz Refresh Rate at 4K Resolution. If you want more, you will need a Coffee Lake processor.

0

TL;DR: Delete ~/.config/monitors.xml and try different a different port on your monitor.

https://askubuntu.com/a/1377633/197395

Worked for both Samsung monitors for me, but may not work for you, but worth a try.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .