0

In previous MAAS versions I successfully deploy a few machines and everything worked fine, but after I updated MAAS to 2.1.3 version using the solution from: https://www.ubuntu.com/download/cloud/autopilot, I am not able to do deploy anything.

Before trying to deploy the machine I commissioned it from MAAS using an Ubuntu 14.04 LTS amd64 image, after that I tried to deploy it using conjure-up with the Landscape spell, but from the logs I see that it can not even be deployed, so it is not a problem of conjure-up because the same problem happens if a I try to deploy it from MAAS UI.

From the logs you can see this: Apr 28 15:52:37 Frenzy cloud-init[1205]: Reading package lists... Apr 28 15:52:37 Frenzy cloud-init[1205]: E: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/xenial/main/source/by-hash/SHA256/cd4de9b666f08e418e4ba56c87504e625ab69cb254eaaf2f79c6a6dc3a4cea4e Hash Sum mismatch Apr 28 15:52:37 Frenzy cloud-init[1205]: E: Some index files failed to download. They have been ignored, or old ones used instead. Apr 28 15:52:37 Frenzy cloud-init[1205]: Cloud-init v. 0.7.9 running 'modules:config' at Fri, 28 Apr 2017 15:52:16 +0000. Up 85.94 seconds. Apr 28 15:52:37 Frenzy cloud-init[1205]: 2017-04-28 15:52:37,887 - util.py[WARNING]: Running module ntp () failed

Has someone had the same problem? How could be fixed?

0

That to me looks like nodes in deployment can't reach the repositories. If you are using the MAAS node as a proxy to the internet make sure your IPTABLES is setup to NAT the nodes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.