0

I've vsftpd user dev which is the member of www-data. Every file I upload through ftp gets dev as owner and www-data as a group. I can access the website through the browser and able to login and make content changes in the Wordpress backend. But It gives me a permission error Cannot Create Directory when I try to install Theme or Plugin. Everytime I've to change the folder and files ownership to www-data user to make it work.

Please help me to solve this hurdle.

  • did you set the vsftpd.conf well – George Udosen May 1 '17 at 18:06
  • what I did in addition to setting up the vsftpd.conf I created a replica of my dev folder in /home/$USER then i added this in my /etc/fstab /var/www/html /home/george/www none bind 0 0 so its mounted at boot. I now access it from wordpress and so development as though on the web – George Udosen May 1 '17 at 18:12
  • @George in vsftpd.conf I set it to local_umask=022 – Avtar Nanrey May 2 '17 at 19:25
  • Did you setup the SSL Certificates, write_enable=YES, local_enable=YES? – George Udosen May 2 '17 at 19:56
  • I didn't setup the SSL Certificates but yes write_enable=YES, local_enable=YES is there. – Avtar Nanrey May 2 '17 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.