0

I have Haier Y11B Tablet-PC I have to install Ubuntu in it but my friend told me there is driver problem in Ubuntu with this laptop (He tried it). So I just tried Ubuntu directly from USB and yes It has problem. Then While Installing Ubuntu tried to connect but got same response.

When I try to connect wifi it just keeps trying and then nothing happens. It works perfectly fine with Windows. Ubuntu version is 16.10

Here is driver details from windows. enter image description here

Here is details with lsmod in Ubuntu

enter image description here

Two more results as asked in comments.

lsusb and lspci results

enter image description here

I will test it with direct USB if it works fine then will install Ubuntu.

Any luck ?

  • Edit to include results for lsusb in Ubuntu with the device connected – Jeremy31 May 1 '17 at 21:34
  • updated take a look. – Adnan Ali May 2 '17 at 11:31
1

From the usb.id you posted above and from lsmod, we see that your device uses the driver rtl8xxxu. When you run a live session from the USB, check to see what driver is loaded:

lsmod | grep rtl

It is a relatively new driver and, so far, we are unaware of any problems. Of course, it is easy enough to find out for sure. Run the live session for a few days and try it. If it works correctly, then proceed to install Ubuntu.

If you are still having trouble connecting, please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

  • lsmod | grep 8723 it shows nothing. I just tried lsmod in output there was rtl8xxxu 126976 0 mac80211 757760 1 rtl8xxxu – Adnan Ali May 1 '17 at 17:33
  • sudo modprobe -r rtl8723be it also do nothing – Adnan Ali May 1 '17 at 18:02
  • We suspect then that yours is not an rtl8723be device. Once we identify your device, I will amend my answer. Please edit your question to add the result of: lspci -nnk | grep 0280 -A2 – chili555 May 1 '17 at 19:59
  • lspci -nnk | grep 0280 -A2 dont works. only lspci -nnk gave output, I am updating it. – Adnan Ali May 2 '17 at 11:11
  • I have revised my answer. Please check. – chili555 May 2 '17 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.