0

I know there are a few of these posts but please bear with me because I have still not been able to mount USB flash drives in my Windows 10 guest OS.

  • My host system is Ubuntu 16.04
  • My VirtualBox version is 5.0.36
  • I have installed the Oracle extensions for VirtualBox
  • I have also installed the guest addtions
  • My guest OS is Windows 10
  • I have added my user to the vboxusers groups When I right click at the bottom of the VB interface and select a USB device to mount I hear the Widows 'alert' sound that indicates new hardware detected, but the drive is never mounted, or installed. Doesn't show up in the disk manager either. I thought it might be an issue with that VM so I tried on several others (all Windows) and I got the same result.
  • I use KVM rather than virtualbox, but you may try updating your program to the current version, which is virtualbox 5.1.22 – Charles Green May 1 '17 at 14:26
  • Does it happen with different USB drives? – Katu May 1 '17 at 14:53
  • Hi, Katu. Yes, it happens with various USB drives. – ptee May 1 '17 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.