6

I've always used my Gmail accounts with Thunderbird. Until two days ago I was using them and then I decided to install Ubuntu Gnome 16.04 - which I had previously used and worked fine with Gmail+Thunderbird -, now I can't get through the Google sign in to configure my imap gmail account.

I enter the appropriate info and when I hit done it goes to that usual google page where you have to enter your username and then hit next to enter the password. That's when it gets stuck: I hit next and nothing happens.

Any ideas?

1
  • 1
    This question looks related, although there does not appear to be a good answer there yet. Commented May 1, 2017 at 0:15

4 Answers 4

4

You'll have to install the beta version of Thunderbird. Please follow these steps.

  1. Open a terminal window;
  2. Uninstall current version of thunderbird by entering:

    sudo apt-get remove thunderbird
    
  3. Add "thunderbird-next" ppa (contains releases of Thunderbird from the beta channel) by entering:

    sudo add-apt-repository ppa:mozillateam/thunderbird-next
    
  4. Download the package lists from the repositories and update them by entering:

    sudo apt-get update
    
  5. Install the new version of Thunderbird by entering:

    sudo apt-get install thunderbird
    
  6. After installation ends close the terminal window. Now you should have the 1:54.0 version of the software. You can check this opening thunderbird, and clicking "Help" > "about thunderbird" from the menu. A new window appears informing the version.

  7. Now you can configure the Google account normally.

1
  • It worked. Thank you so much! (Actually, I had to reboot for it to work. Just reinstalling TB wasn't enough, even doing apt update)
    – fmb
    Commented May 1, 2017 at 1:53
2

That was a bug in Thunderbird 52.0.1, concerning improvement on Google sign-in process on Apr 20, 2017.

see: https://developers.googleblog.com/2016/08/modernizing-oauth-interactions-in-native-apps.html

And it was fixed in Thunderbird 52.1.0 released today, Apr 30, 2017.

refer to https://bugzilla.mozilla.org/show_bug.cgi?id=1359297

2

Alternate Workaround:

If anyone needs a workaround for any reason as I did, here is one option to consider to get your gmail working in Thunderbird without the patch or beta release.

First in your gmail account you will need to have “Allow less secure apps” turned on. You can always turn this back off when you have OAuth working again. here is the link to the setting. Google tool screenshot

Next, In Thunderbird > account settings > server settings > Change the Authentication method from “OAuth” to “Normal Password”.

Last change the SMTP server settings to normal as well (to be able to send out email).

This got me back into my email when I can’t get the latest patch for Thunderbird easily.

0

Just had this (or something similar) in Thunderbird 78.8.1 on Ubuntu 20.4.2 after changing a Gmail password - though I'm assuming that "nothing happens" is shorthand for "it doesn't do what I want" : when I clicked "Next" it reverted to the e-mail entry screen but without the autocompleted address, so something happened, but it didn't get me any further.

Steve's workaround ("normal password") gets around things nicely, but I was able to get where I wanted without allowing "less secure" access or uninstalling / reinstalling anything.

It looks like OAuth2 tokens are considered as cookies by Thunderbird, so allowing cookies temporarily in Preferences / Privacy and Security / Web content, deleting both (POP/IMAP and SMTP) stored passwords for that account in Preferences / Privacy and Security / Saved Passwords, coming out of Thunderbird and going back in again will give the same Google prompt with autocompleted e-mail address, but now clicking "Next" prompts for the new password and connects to Gmail, which seems to overwrite the OAuth token.

Cookies can then be disabled again.

[This won't help if you initially had cookies enabled, but I haven't seen the same problem with those settings.]

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .