0

I am running Xubuntu 16.04.1, doing some testing with XFCE experimental packages from a PPA I have messed up my Xubuntu desktop.

Upon realising the mistake I purged all the experimental packages from the PPA.

However to my regret I noticed later that seahorse was not working as it should.

After a while I noticed the LightDM login screen did not have the "Xubuntu Session" and only contained "Xfce Session", after reinstalling the xubuntu-desktop package the "Xfce Session" came back on LightDM and Seahorse began to handle my ssh keys again.

However a couple of days later I discovered that not everything is working on Seahorse.

1) The "Login" section within seahorse is missing and it does not work for GVFS connections (SMB/FTP) it makes connections take a long time to establish and they always come with a login request.

2) Chromium takes forever to start (I guess it is trying to communicate with the keyring and until it times out/fail it does not finish starting.

3) Worse of all I can't configure VPNs on network manager as the options are grayed out, using nm-connection-editor does not work either, all settings in the vpn are shown grayed out, I guess it is because the password is read/stored on the keyring.

I have checked system logs and tried to run things from the console trying to figure out what is wrong with Seahorse, I can see that the keyring login files are still present: "/home/[username]/.local/share/keyrings/login.keyring" but for the life of me I have no clue what's wrong with it.

My Guess is that perhaps some of the packages changed something or that after purging I may have removed some library or dependency that Seahorse needs.

So far I have tried to reinstall seahorse, networkmanager, all the vpn addons for network manager and gvfs, libgnomevfs2... to no effect.

Can anyone provide with any clues?

  • I have no Xubuntu experience, but have had problems on Lubuntu systems if libpam-gnome-keyring is not installed. – Organic Marble Apr 30 '17 at 14:00
  • I had that package installed, I reinstalled it just in case, but no change. Note that my problem has to do with the "login" section from within Seahorse disappearing, the keyring unlocks at login and works for Certificates, PGP Keys and SSH, it is anything that lives inside the "Login" section that doesn't work. – PizPez Apr 30 '17 at 16:44
  • 1
    After installing Xubuntu on a VM I have noticed that the name of the missing section is Passwords. – PizPez May 3 '17 at 20:19
  • In the end and desperate to fix this I ended reinstalling the Operating system from scratch. I tried to read as much as I could, alas I was unable to find a solution. – PizPez Jun 4 '17 at 18:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.