0

I upgraded to 16.04 three weeks back. In my /usr/bin I have all python versions from 2.7 to 3.5. By default /usr/bin/python pointed to python2.7. I tried to make it point to python3.5.

I went through some tech site instructions and ended up creating a softlink /usr/bin/python3.5 -> /usr/local/bin/python but /usr/local/bin/python didn't exist. In an attempt to clean up the broken /usr/bin/python3.5 link, I also ended up deleting the /usr/bin/python3.5 executable. I tried to upgrade python or my distribution but I am getting errors.

How can I fix this? I can't open gnome-terminal.

Screenshot 1

Screenshot 2

0

Do not use upgrade follow the instructions here I deleted package 'python3' on Ubuntu and I have lost dashboard, terminal and Unity. Help me to restore my data please

In future use update-alternatives instead of creating symlinks manually https://linuxconfig.org/how-to-change-from-default-to-alternative-python-version-on-debian-linux

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.