3

I'm 1-day old to Linux, so excuse me if my question is not very clear!

I have my Windows 10 on HDD. I added an SSD and installed Ubuntu on it. Both boot perfect except Windows is always the default and have to press F12 and select to boot from SSD to get into Linux.

I am trying to add Windows to Grub so I would have the option to either boot to linux or window without going to boot options every time.

My BIOS settings:

Boot option: UEFI
Secure Boot: Disabled
Load legacy option rom: Enabled

When I do

    sudo os-prober

it returns nothing. But here is what I get from

    majid@majid-Inspiron-3650:/$ sudo fdisk -l
    Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: A00CF40F-766A-49C4-9811-9FA77132D84B

    Device          Start        End    Sectors  Size Type
    /dev/sda1        2048    1026047    1024000  500M EFI System
    /dev/sda2     1026048    1288191     262144  128M Microsoft reserved
    /dev/sda3     1288192 3878694911 3877406720  1.8T Microsoft basic data
    /dev/sda4  3878694912 3879616511     921600  450M Windows recovery environment
    /dev/sda5  3879616512 3907028991   27412480 13.1G Windows recovery environment


    Disk /dev/sdb: 232.9 GiB, 250059350016 bytes, 488397168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0xe46bb810

    Device     Boot     Start       End   Sectors  Size Id Type
    /dev/sdb1  *         2048 454959103 454957056  217G 83 Linux
    /dev/sdb2       454961150 488396799  33435650   16G  5 Extended
    /dev/sdb5       454961152 488396799  33435648   16G 82 Linux swap / Solaris
  • 2
    You did not use gpt for sdb. And then it looks like you probably used legacy/BIOS/CSM boot mode for Ubuntu. Better to have installed in UEFI boot mode. And also better to partition in advance & include an ESP on the SSD. But grub only uses the ESP on drive seen as sda. UEFI & BIOS are not compatible, once you start booting in one mode, you cannot change. Or BIOS grub cannot boot UEFI Windows. askubuntu.com/questions/743095/… & help.ubuntu.com/community/UEFI – oldfred Apr 30 '17 at 3:39
  • I used Rufus to make bootable usb for ubuntu. Under Partition scheme I chose MBR partition for BIOS or UEFI. Should I choose GPT scheme for UEFI option? – Majid Apr 30 '17 at 3:49
  • @Majid Yes, of course. Please read the links above. – user589808 Apr 30 '17 at 11:44
  • For the installer, most systems do not matter whether MBR or gpt and then installer can install in either UEFI or BIOS. But actual install to another drive needs to be UEFI/gpt if Windows is UEFI. – oldfred Apr 30 '17 at 13:23
2

Thanks @oldfred and @CelticWarrior,

Here is what I did at the end:
BIOS setting:
- Boot option: UTFI
- Secure boot: Disabled
- Load Legacy Option Rom: Disabled

I also made new bootable usb with GPT scheme for UEFI. Everything went smooth during installation. Now, when I reboot my computer it asks me to boot to Ubuntu or Windows. Perfect!

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.