2

I have Kubuntu 16.04, Inkscape 0.92 and TexText 0.4.4.

TexText has worked without any problem for a long time, however, it suddenly stopped working and I am trying to track down the issue. I already reinstalled Inkscape and TexText, still no working.

Here is the error I am receiving (already look it up on google, no aid found):

Traceback (most recent call last):
  File "textext.py", line 210, in cb_ok
    self.callback(self.text, self.preamble_file, self.scale_factor)
  File "textext.py", line 369, in <lambda>
    converter_cls, old_node))
  File "textext.py", line 387, in do_convert
    new_node = converter.convert(text, preamble_file, scale_factor)
  File "textext.py", line 751, in convert
    self.pdf_to_svg()
  File "textext.py", line 849, in pdf_to_svg
    + pstoeditOpts)
  File "textext.py", line 596, in exec_command
    % (' '.join(cmd), p.returncode, out + err))
RuntimeError: Command pstoedit -f plot-svg /tmp/tmpRoqG9M/tmp.pdf /tmp/tmpRoqG9M/tmp.svg -dt -ssp -psarg -r9600x9600 failed (code 1): pstoedit: version 3.70 / DLL interface 108 (built: Mar 13 2016 - release build - g++ 5.3.1 20160311 - 64-bit) : Copyright (C) 1993 - 2014 Wolfgang Glunz
Error: /invalidaccess in --run--
Operand stack:
   false   --dict:30/32(L)--   typecheck   --nostringval--   -ueofill   ueofill   false   --nostringval--   --nostringval--   ueofill   --nostringval--   -ufill   ufill   false   --nostringval--   --nostringval--   ufill   --nostringval--   -shfill   shfill   false   --nostringval--   --nostringval--   shfill   --nostringval--   -showpage   showpage   false   --nostringval--   --nostringval--   showpage   --nostringval--   -awidthshow   awidthshow   false   --nostringval--   --nostringval--   awidthshow   --nostringval--   -rectstroke   rectstroke   false   --nostringval--   --nostringval--   rectstroke   --nostringval--   -stringwidth   stringwidth   false   --nostringval--   --nostringval--   stringwidth   --nostringval--   -charpath   charpath   false   --nostringval--   --nostringval--   charpath   --nostringval--   -ge   ge   false   --nostringval--   --nostringval--   ge   --nostringval--   -rectfill   rectfill   false   --nostringval--   --nostringval--   rectfill   --nostringval--   -glyphshow   glyphshow   false   --nostringval--   --nostringval--   glyphshow   --nostringval--   -concat   concat   false   --nostringval--   --nostringval--   concat   --nostringval--   -image   image   false   --nostringval--   --nostringval--   image   --nostringval--   -currentcmykcolor   currentcmykcolor   false   --nostringval--   --nostringval--   currentcmykcolor   --nostringval--   -currentrgbcolor   currentrgbcolor   false   --nostringval--   --nostringval--   currentrgbcolor   --nostringval--   -string   string   false   --nostringval--   --nostringval--   string   --nostringval--   -lt   lt   false   --nostringval--   --nostringval--   lt   --nostringval--   -stroke   stroke   false   --nostringval--   --nostringval--   stroke   --nostringval--   -setgstate   setgstate   false   --nostringval--   --nostringval--   setgstate   --nostringval--   -eofill   eofill   false   --nostringval--   --nostringval--   eofill   --nostringval--   -rectclip   rectclip   false   --nostringval--   --nostringval--   rectclip   --nostringval--   -eoclip   eoclip   false   --nostringval--   --nostringval--   eoclip   --nostringval--   -clip   clip   false   --nostringval--   --nostringval--   clip   --nostringval--   -ustroke   ustroke   false   --nostringval--   --nostringval--   ustroke   --nostringval--   -colorimage   colorimage   false   --nostringval--   --nostringval--   colorimage   --nostringval--   -restore   restore   false   --nostringval--   --nostringval--   restore   --nostringval--   -imagemask   imagemask   false   --nostringval--   --nostringval--   imagemask   --nostringval--   -save   save   false   --nostringval--   --nostringval--   save   --nostringval--   -fill   fill   false   --nostringval--   --nostringval--   fill   --nostringval--   -grestore   grestore   false   --nostringval--   --nostringval--   grestore   --nostringval--   -definefont   definefont   false   --nostringval--   --nostringval--   definefont   --nostringval--   -gsave   gsave   false   --nostringval--   --nostringval--   gsave   --nostringval--   --dict:5/5(G)--   false   DefaultGray   --dict:5/5(G)--   ColorSpace   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1976   1   3   %oparray_pop   1975   1   3   %oparray_pop   1959   1   3   %oparray_pop   1852   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   1976   229   3   %oparray_pop   1975   229   3   %oparray_pop   1959   229   3   %oparray_pop   --nostringval--   --nostringval--   2   1   1   --nostringval--   %for_pos_int_continue   --nostringval--   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1202/1684(ro)(G)--   --dict:1/20(G)--   --dict:302/450(L)--   --dict:302/450(L)--   --dict:132/256(ro)(G)--   --dict:283/300(ro)(G)--   --dict:26/32(G)--   --dict:0/6(G)--
Current allocation mode is global
Last OS error: No such file or directory
Current file position is 87896
GPL Ghostscript 9.18: Unrecoverable error, exit code 1
PostScript/PDF Interpreter finished. Return status 256 executed command : /usr/bin/gs -I/home/toquica/.fonts -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS -r9600x9600 "/tmp/psinovekHv"
The interpreter seems to have failed, cannot proceed !
  • I just ran into the same problem. My update log says there was a ghostscript update a couple of days ago. If this is indeed the cause of the problem, you could try to revert back to the old ghostscript version. – Praan May 1 '17 at 12:35
3

I confirm this is due to the ghostscript update: reverting back to ghostscript 9.18~dfsg~0-0ubuntu2 fixes the problem. So there is some regression in the updated version (9.18~dfsg~0-0ubuntu2.4).

UPDATE: the bug has been reported at https://bugs.launchpad.net/ubuntu/+source/ghostscript/+bug/1687614

UPDATE 2 (17 May 2017): the fix has just been released by Ubuntu, so it suffices to run the software updater to get rid of the problem.

  • 2
    Thanks, this worked like a charm: 1) downgrade libgs9 to 9.18~dfsg~0-0ubuntu2 with sudo apt-get install libgs9=9.18~dfsg~0-0ubuntu2 2) downgrade ghostscript to 9.18~dfsg~0-0ubuntu2 with sudo apt install ghostscript=9.18~dfsg~0-0ubuntu2 3) reinstall pstoedit with sudo apt-get install pstoedit After this, the system will detect the packages out of date, you maybe want to hold back the packages to prevent automatic updates – Hans May 3 '17 at 11:37
  • This worked for me! – auraham May 8 '17 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.