0

I'm trying to create a dual boot with Ubuntu 16.04 and Windows 10 on my Inspiron-15-3000 series following this tutoriel in French made by Playmatic24

I didn't achied it when notifying many differences :

  • I don' have a partition sdb along an sda
  • I think I disactivated the UEFI when uploading Ubuntu 14.4 for the fist time one year ago and some messaged pop-uped to warn me about something about it. May I follow up installation if I clicked on "not to force the uefi mode installation" ?

Here is a screenshot of the option where I stopped before choosing the "other option" installing option. enter image description here - I had a weird "ubuntu" option for booting in the grey and blue screen. Maybe it is normal because of my first Ubuntu 14.4 or 16.4 installations ...

My question is : may I have continued by partitioning with the three mounting option (for /, /home and the lastion I don't remember the name...) or do I miss something?

I tried then this tutorial in English from everydaylinuxuser.com, changing my fast boot option and secure boot option to down and now I'm not able to boot on Windows anymore, even from the blue and grey screen.

Update 2/5/2017

Here is the boot info :

http://txt.do/drvsx

  • The link to the boot-info summary is not correct, nothing to see there. – mook765 May 1 '17 at 20:29
  • @mook765 It is the only thing I get from boot-info – ThePassenger May 1 '17 at 23:37
  • @mook765 I don't know what the issue is when creating an url but here is the boot-info created as a local text – ThePassenger May 2 '17 at 7:33
  • 1
    Yes , this is more helpful. It appears that just right now only Windows is installed, and Windows is installed in legacy-mode. You should install Ubuntu in legacy-mode too, if you install Ubuntu in UEFI-mode, you will run into problems. To install Ubuntu in legacy-mode, you have to boot the installer in legacy-mode. In the BIOS boot menu you will see two items for your installer, one of them starts with UEFI:. You have to choose the other one. – mook765 May 2 '17 at 7:48
  • @mook765 Understood. Is it normal that I'm not able to boot on windows now from the blue and grey screen ? – ThePassenger May 2 '17 at 10:11
2

I don't speak French, so I can't follow a French YouTube video. That said, I have some comments on your query:

  • /dev/sda and /dev/sdb are entirely separate physical hard disks, not partitions. If your guide showed both but you have just one, it means that you have fewer hard disks than whoever wrote the guide. (The installation medium itself might show up as /dev/sdb, though, which can complicate the comparison.) Partitions are numbered and referred to with numbers following the disk device filename, as in /dev/sda2 or /dev/sdb4.
  • As a general rule, if you want to dual-boot Ubuntu with an existing OS, you should NOT adjust EFI/UEFI vs. BIOS/CSM/legacy boot options. See my page on the CSM for a detailed presentation on why this is so.
  • It's hard to tell from your description how your computer is set up. To provide detailed information, please run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here.

I recommend you read the following pages:


EDIT: Your existing Windows installation is definitely in BIOS/CSM/legacy mode. As such, you should not attempt to install Ubuntu in EFI/UEFI mode. To avoid doing so, you must learn to control the boot mode of your computer. This involves both properly creating your boot media and somehow selecting the boot mode used to boot an individual medium. Typically, you'll see two options for a USB drive, one with the string "UEFI" and one without it. Selecting the one without "UEFI" is the appropriate choice. Read my page on the CSM (referenced above) for more information; however, that page is written mainly for people who have EFI-mode Windows installations and who might be tempted (through frustration or bad instructions) to install Linux in BIOS mode. You have the opposite problem.

  • This is too much complicated for me. I just wanted to know wether to click or not on force the uefi mode installation. I followed another tutorial turning off secure boot and fast boot and now my pc isn't even booting on Windows anymore – ThePassenger May 1 '17 at 18:46
  • Neither Secure Boot nor Fast Boot options should affect Windows' ability to boot, so I suspect you did something else to affect it -- either a firmware setting or an accidental change to on-disk files. It's impossible to offer you more advice without detailed information on your current configuration, such as from the Boot Repair utility to which I referred in my answer. – Rod Smith May 1 '17 at 18:59
  • Okay, I just ran the boot-repair in the terminal and added the url which is quite odd as far as I only have paste2.org . I did it from the try ubuntu OS – ThePassenger May 1 '17 at 19:08
  • Please see my edit, above. – Rod Smith May 2 '17 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.