0

this is my first Stack Exchange, so sorry if this request is formatted wrong.

I was wondering why I can't change the display language from Español (España) to Español (Latinoamérica). In previous versions of Ubuntu, I've been able to switch between different dialects of Spanish without any problem. But when I made a clean install of version 17.04, even when Spanish is installed, I can only use the dialect of spanish used in Spain. As you can see in this picture, only Español (España) is available to change to, even though Spanish is installed.

EDIT: Español (Chile) was added to the Language Support menu when I turned my PC on, and there wasn't any indication as to why. I don't know what's going on here...

Do I have to install different dialects of Spanish somewhere else now? Thanks in advanced.

0

Choosing the language is about determining which translations should be used for displaying menus and messages, and there is only one set of Spanish translations available in Ubuntu. It wouldn't make much sense to show 20 or so Spanish options, since they all would result in the same behavior.

  • I'm puzzled as to what you're trying to say. I think you could mean that all the dialects of Spanish are the same. That, however, isn't the case. Many words are often exclusive or more frequently used in certain dialects of Spanish, and an entire verb conjugation is treated differently in Costa Rican Spanish, for example. What you probably mean, though, is that the menu in Installed Languages only shows the language name to prevent clutter. Even so, installing Spanish from this menu only adds one dialect of Spanish to the Language Support window. – Caleb May 2 '17 at 21:46
  • @Caleb: No, I know that there exist multiple Spanish dialects. What I mean is that nobody has translated Ubuntu into any other Spanish dialect but Spanish as spoken in Spain. That's why the menu only shows one option. You can compare it with Portuguese: Ubuntu is translated into both Portuguese as spoken in Portugal and Brazilian Portuguese. Hence those two options are available if you install Portuguese. – Gunnar Hjalmarsson May 3 '17 at 1:14
  • Are you sure, because Español (Chile) had just recently popped up without warning. Maybe this is some kind of issue with my language installation, maybe Ubuntu was just recently translated into Chilean Spanish, I don't know. – Caleb May 4 '17 at 22:42
  • @Caleb: Where did Español (Chile) pop up? – Gunnar Hjalmarsson May 5 '17 at 3:01
  • In the "Language for menus and window" section when you open up Language Support. – Caleb May 6 '17 at 18:32
0

For keyboard input simply go to System Settings > Keyboard Text Entry and specify Spanish.

In Terminal type gnome-language-selector click install/remove and install Spanish.

After that switch to Regional Format, and in display language select your specific Spanish and click apply system-wide to make changes.

enter image description here

If you can't access install language in language support see How to install additional language packs on Ubuntu Gnome 15.04?

If that doesn't help try changing some options in Software and Updates: select Download from Main Server and run sudo apt-get update and then restart, and try running gnome-language-selector again.

  • Thanks, but the currency and date format isn't what I'm trying to change. I'm trying to add another dialect of Spanish to the Language Support – Caleb May 2 '17 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.