1

I have Ubuntu and Windows both installed on my first drive. On Windows, my second drive works fine. When I try to mount it in Ubuntu it tells me:

mount: can't find /dev/sdb2 in /etc/fstab

Here is my fstab:

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=7bd442e2-28aa-488b-a592-cfe2fff95022 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=b2f8e207-5f5c-4217-9cae-10aeaac998c7 none            swap    sw              0       0

It still shows my hdd in disks

here is the fdisk -l /dev/sdb output:

Disk /dev/sdb: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: B36EE60F-CD10-11E6-B574-D050992F2DD1

Device      Start        End    Sectors   Size Type
/dev/sdb1      34     262177     262144   128M Microsoft reserved
/dev/sdb2  264192 1953523711 1953259520 931,4G Microsoft Storage Spaces
  • sdb2 looks like an unknown file system. This can happen if it's NTFS and has an unclean file system. In Windows, run chkdsk /f d: changing the "d" to the correct Windows drive letter for sdb2. You also don't have a fstab entry for it, if you want it to automount. – heynnema Apr 29 '17 at 14:53
  • chkdsk didn't find any errors. – Mithos23 Apr 29 '17 at 15:54
  • Your NTFS file system is corrupt on sdb2. I'd backup your data, delete sdb2 and recreate it as NTFS, then restore your data. It shouldn't show up as "Microsoft Storage Spaces", it should be "Microsoft Basic Data". – heynnema Apr 29 '17 at 16:27
0

That error is only triggered when a location to mount wasn't specified in the command and the device isn't listed in the /etc/fstab file. Based on the fstab file you've added, it doesn't show a /dev/sdb2. A blkid command output would be helpful in this instance since we could compare the UUIDs to the sd* device names. A sure fire way to avoid that particular error message is to specify the directory you would like to mount the disk:

mount -t fstype /dev/sdb2 /path/to/mount

You'll need to run the above command with root permissions or with sudo. Also, replace "fstype" with the actual filesystem type, such as ntfs.

0

Based on the fdisk output showing that the partition is a "Microsoft Storage Spaces" it may not be possible to mount in Linux. Your solution would be to choose something like NTFS. For those at home getting this error with NTFS, in some cases with NTFS having this issue you can resolve with ntfsfix. To start, install the package that has that utility. Depending on your version of Ubuntu that will be in ntfsprogs or ntfs-3g:

sudo apt-get install ntfsprogs or sudo apt-get install ntfs-3g

and then:

sudo ntfsfix /dev/sdb2

However, I would strongly recommend making a backup first, especially if the fdisk output did not indicate NTFS. I don't know for sure what this would do to a Microsoft Storage Spaces partition.

Also, remember to include the destination mount point in your mount command since /dev/sdb2 is not included in your /etc/fstab file. (that's what the "sdb2 is not in your fstab" error was about)

  • I would advise against the use of ntfsfix... unless you'd like to corrupt your C: disk, or loose data there. Of course, we're talking about sdb2 where the ntfsfix command won't do anything anyway, as all it does is wipe out the hibernation file and clear the dirty flag/set the clean flag. ps: you need to either delete one of your answers, or combine them into one. ps2: you copied my answer/comment. – heynnema Apr 29 '17 at 17:01
  • @heynnema I haven't had any experiences corrupting C: or losing data using ntsfix. However, when dealing with any type of filesystem metadata it's always good to make a backup just in case. That's why I've recommended making a backup first. – TopHat Apr 29 '17 at 17:47
  • Consider this. In Windows, the hibernation file stores the last known condition of Windows. Lets say that the last thing that you did in Windows was to edit a file, but the disk buffer hasn't been written out to disk yet. Then, outside of Windows, you delete the hibernation file. What do you think happened to the unwritten disk buffer? Simple example. Lost data. – heynnema Apr 29 '17 at 18:51
0

From the comments...

sdb2 looks like an unknown file system. This can happen if it's NTFS and has an unclean file system. In Windows, run chkdsk /f d: changing the "d" to the correct Windows drive letter for sdb2. You also don't have a fstab entry for it, if you want it to automount.

Since the chkdsk was clean... and fdisk shows the problem...

Your NTFS file system is corrupt on sdb2. I'd backup your data, delete sdb2 and recreate it as NTFS, then restore your data. It shouldn't show up as "Microsoft Storage Spaces", it should be "Microsoft Basic Data".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.