3

This question already has an answer here:

I have installed Ubuntu 17.04 Zesty Zepus on my computer. I have been unable to connect to any wireless network with 17.04, whether from using the live USB during installation or after it has been installed. I experienced.no problems on 16.04. Although Ubuntu can see my network in 17.04, it cannot connect and it says "Disconnected".

EDIT:

I have followed Jeremy31's commands. The Internet seems to work now, and it works quite well. I had problems installing Steam and Chrome from .deb files with the Ubuntu Software program, so that's why I thought the Internet was malfunctioning. Gdebi fixed that issue.

I have entered my wireless-info.txt file to the link below which I received by entering the commands

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && \
chmod +x wireless-info && \
./wireless-info

http://paste.ubuntu.com/24485625/

Output of lsusb:

ID 148f:3572 Ralink Technology, Corp. RT3572 Wireless Adapter

marked as duplicate by Sumeet Deshmukh, Zanna, Anwar, Ravexina, David Foerster May 24 '17 at 10:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

6

This is likely due to a bug. A fix is to edit /etc/NetworkManager/NetworkManager.conf (e. g. with gksudo gedit /etc/NetworkManager/NetworkManager.conf) and add the following to the file:

[device]
wifi.scan-rand-mac-address=no

Save and exit the text editor, then run:

systemctl restart network-manager.service

Some USB devices perform poorly when power management is enabled for wifi, it can be disabled by

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
systemctl restart network-manager.service
  • Ok I'll try it out in a couple of hours – Fah11277 Apr 29 '17 at 16:15
  • Hi Jeremy31, I tried it and I can connect now, but the internet is very slow. I can search on google but it took 10 minutes to open any other page. Is there a setting I can change to fix this? Is there a way to turn on power management for wifi, could turning it off create a problem (as I have done)? – Fah11277 Apr 30 '17 at 6:54
  • You can enable power management again with sudo sed -i 's/wifi.powersave = 2/wifi.powersave = 3/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf – Jeremy31 Apr 30 '17 at 9:46
  • It may help to change the encryption on the wireless router to WPA2 only without standard WPA, WEP, or TKIP enabled – Jeremy31 Apr 30 '17 at 17:06
  • I'm not sure if I did something wrong but running systemctl restart network-manager.service with "sudo" made it work for me. – user1821961 Aug 12 '17 at 15:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.