1

I've installed virtualbox version 5.1.20 and vagrant version 1.9.4 and then when I ran vagrant up, I got the following error

Command: ["hostonlyif", "create"]

Stderr: 0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to create the host-only adapter
VBoxManage: error: VBoxNetAdpCtl: Error while adding new interface: VBoxNetAdpCtl: ioctl failed for /dev/vboxnetctl: Inappropriate ioctl for devic
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component HostNetworkInterfaceWrap, interface IHostNetworkInterface
VBoxManage: error: Context: "RTEXITCODE handleCreate(HandlerArg*)" at line 94 of file VBoxManageHostonly.cpp

I fount this answer here Could not load 'vboxdrv' after upgrade to Ubuntu 16.04 (and I want to keep secure boot) but when I get to the third step sudo mokutil --import MOK.der, I got the following error

EFI variables are not supported on this system

I'm running Ubuntu 16.04.

8

I have spent hours and hours, trying various combinations of virtualbox and vagrant, no luck.

Remove virtual box or any old versions of it.

sudo apt remove virtualbox virtualbox-5.0 virtualbox-4.*

Then try using one of ubuntu repositories to install

sudo apt-get install virtualbox

Worked for me.

| improve this answer | |
  • 1
    This is weird, but working like charm. – sobi3ch Jun 27 '17 at 7:04
4

Restarting network manager should help:

sudo modprobe vboxnetadp
| improve this answer | |
  • That indeed helped so thanks. But out of curiosity: what could be the source problem so that this helped? :) – Tomasz Kapłoński Mar 28 '19 at 11:12
  • Also, that works in case you just updated the virtualbox and cannot launch your vm via vagrant up because that VBoxManage fails to setup a host-only network as well. – Dimitrios Desyllas Jan 21 at 8:50
0

I had the same problem and the apt remove install answer did not work for my (Ubuntu 16.04) I did get it to work by using sudo apt remove virtualbox virtualbox-5.0 virtualbox-4.* and then installing the 5.1 .deb file from virtualbox VirtualBox 5.1 downloads

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.