0

I have a windows laptop, and I have a Ubuntu 16.04 desktop which has 3 hard drives in it:

  1. 500GB Ubuntu 16.04 OS hardrive.
  2. 1TB - Raid 1 (Ubuntu Raid) Hard drive A (nfts)
  3. 1TB - Raid 1 (Ubuntu Raid) Hard drive B (nfts)

The raid pair is where I back everything to. I am not a pirate so these are all personal files, and made a raid array because losing this data is unrecoverable and would be devastating.

I spent the day trying to get my Linux box to share the raid files with my Windows laptop via Samba. Finally after about 2 days of reading and trying, it start working. I started coping files from my laptop onto the raid array over my home network, after copying about 100MB the copying hangs, and linux PC has had problems.

In a recovery mode I removed the raid array, and removed the line to auto mount the raid array from fstab (required for Samba), my OS linux hard drives boots. But I cant seem to be able to get the raid array back.

If I try boot Ubuntu I get this (googling shows some people reckon it is SATA cables, so I tried swapping each cable out but it did not help): Failures while trying to boot

If I then run fsck manually I get the following: Result of running fsck

I have read fsck only works with ext, and chkdsk just zeros partitions and causes data loss.

This is what blkid returns with just one of the raid drives attached (currently I have booted from a live cd)

ubuntu@ubuntu:~$ sudo blkid
/dev/sda: UUID="f034155f-4495-ccd8-9ba0-351aad62b995" UUID_SUB="74666d57-c189-68d3-eee5-7ec9d14e976c" LABEL="server1:0" TYPE="linux_raid_member"
/dev/sdb1: UUID="334b6499-bcdf-41f4-9edc-bc04530c2ee4" TYPE="ext4" PARTUUID="0f4fadcd-01"
/dev/sr0: UUID="2016-07-19-21-27-51-00" LABEL="Ubuntu 16.04.1 LTS amd64" TYPE="iso9660" PTUUID="40a863e7" PTTYPE="dos"
/dev/loop0: TYPE="squashfs"
/dev/sdb5: UUID="d251aded-20ac-40fe-aff0-795bc74f7064" TYPE="swap" PARTUUID="0f4fadcd-05"

cat /proc/mdstat returns: enter image description here

Any tips on how to try recover my life's data? Any help would be greatly appreciated.

  • 1
    What does cat /proc/mdstat return? – Thomas Apr 27 '17 at 18:07
  • @Thomas, I got the following reply (hand type): (initramfs) cat /proc/mdstat Personalities : [raidl] [linear] [multipath] [raid0] [raid6] [raid5] [raid4] [raid10] ??ad0 : active raidl sdc[0] sdb[1] 976631360 blocks super 1.2 [2/2] [UU] [=======>.....................] resync = 40.2% (392949824/976631360) finish=99.7min speed=97558K/sec mused devices: <none> (initramfs) – run_the_race Apr 27 '17 at 19:02
  • @Thomas, okay thank you, it is doing something, if I run the command again I see some progress. I thought it was a prompt waiting for me to give it some commands. – run_the_race Apr 27 '17 at 19:06
  • As you might of found out, you should never rely on a raid as a backup solution. Always keep a backup (external hd, etc...) anyways, I'm curious to know if you were able to get it back? Did it finish the resync? What kind of raid setup is it? Hardware raid, fakeraid, softraid? – nullmeta Apr 27 '17 at 21:45
  • @nullmeta The Sync finished, and after getting a new hard drive and installing ubuntu again on it, and then installing mdadm, it found the raid, and automatically set up the raid again successfully!!! Thanks guys for your help! Yes I am quite tempted to goto the cloud after this. – run_the_race Apr 28 '17 at 15:50
0

at the (initramfs) prompt it is actually performing a resync, even though it appears as nothing is happening. You can check the progress by running:

cat /proc/mdstat

After about 4 hours it completed. It turned out to be hard drive which linux was installed on. I set up the OS again on a new HD, and now it is fine. Thanks guys!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.