I'm struggeling with getting my Zotac Nano Ad10 machine to work with ATI HD 6310 drivers on my Ubuntu 11.10 (64bit) installation.

Here's how I tried to get it to work:

1) Downloaded: http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=

2) Ran it and pressed continue + automatic install.

3) It told me to reboot, so I did.

4) Still slow as crap, went into "Additional drivers" and selected ATI and pressed activate. Rebooted.

5) Still slow, and I checked "System Info" and it said it was still using "VESA:Wrestler", so I tried to reinstall using --force.

6) Ubuntu doesnt boot now, it fail on some crash report thing (can't remember name).

7) I went into prompt, and tried to install the drivers again, but same problem, eventhough installation is successful.

How do I resolve this problem? Can someone tell me what to type step by step? I'm abit new to Linux.


2 Answers 2


There is a post already explaining how to add/remove/revert ATI drivers in your system

Your card is supported by both the open-source or the fglrx driver so you are able to choose.

Since you already installed several versions of the driver in your system I recommend you follow the section to remove the driver completely and revert to the open-source one before trying to install the fglrx driver again.

The recommended version is Catalyst 11.12, they are very stable and fast compared with previous version when using Unity or Gnome-Shell.


I suggest you to re-install ubuntu to start from a clean system. I installed the ati driver by "Additional drivers" as you did and I also can see "VESA:Wrestler" in sytem info but the ati driver is installed, it's just the system ifo which doesn't show good driver.

If you don't want to reinstall, you can try to press CTRL+ALT+F1 once your system crashed to go in terminal mode and edit /ect/X11/xorg.conf if you see driver 'fglrx' type 'vesa' instead and try to reboot.

good luck, tell more info if you can, i will try to help you.

regards, Thierry

  • If he switched from fglrx to vesa on his /etc/X11/xorg.conf file he will be using the vesa driver, not the ATI fglrx one, no matter if the fglrx driver is installed or not. Jan 18, 2012 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.