0

I am trying to install 1Password on Ubuntu 17.04 using Wine, although installation appears to complete program doesn't launch.

If I use Wine Control I can see in console following error:

fixme:mscoree:parse_supported_runtime sku=L".NETFramework,Version=v4.6.1" not implemented
Unhandled loader error: 8, (null) PresentationCore, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 (null)
err:mscoree:expect_no_runtimes Process exited with a Mono runtime loaded.

I did install mono-complete, and not sure how to proceed next, doesn't want to make a total mess. I tried to install NETFramework, Version=v4.6.1 via winetricks, however, it was complaining about using 64bit version.

1

You have to install Mono for Wine which is independent of mono-complete package. I tried to install 1Password and for me installer starts under Wine 2.0. I remember dowloading wine-mono-4.7.0.msi from WineHQ and installing it using:

wine msiexec /i /home/piotr/downloads/wine-mono-4.7.0.msi

If you are running 64 bit version of Wine (which is default in 64bit systems) you need to run 32 bit version of Wine. Rename the wine prefix:

mv ~/.wine ~/.wineOld

Create new 32 bit prefix:

WINEARCH=win32 winecfg

and then you should be able to install wine-mono. I think at the moment it is not possible to install .net in 64 bit version of Wine. If all works well you may want to delete the old .wineOld prefix (unless you have some important applications/data in the old Wine).

  • 1
    when I try to install wine-mono I get following error: fixme:ntdll:NtLockFile I/O completion on lock not implemented yet wine version: 2.0.1 – TheFullResolution Apr 27 '17 at 12:53
  • Do you run wine as root maybe? If yes - you should not run it as root. – Tahtisilma Apr 27 '17 at 13:03
  • No, I don't, I followed only instruction on the page... – TheFullResolution Apr 27 '17 at 13:04
  • Can you provide result of winetricks list-installed? I have the following packages installed on my wine: colorprofile, consolas,corefonts,dotnet11, dotnet11sp1,dotnet20, mshflxgd, tahoma, vcrun2003,vcrun2010 – Tahtisilma Apr 27 '17 at 13:09
  • I get following info: ou are using a 64-bit WINEPREFIX. Note that many verbs only install 32-bit versions of packages. If you encounter problems, please retest in a clean 32-bit WINEPREFIX before reporting a bug. ------------------------------------------------------ Using winetricks 20170327-next - sha256sum: c27f14651a9e0c3fb1d8b9dfd18777cccabe3b37d19553e200b4cf7bc90fcaa2 with wine-2.0.1 and WINEARCH=win64 20170327 colorprofile consolas corefonts – TheFullResolution Apr 27 '17 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.