6

In Ubuntu 16.04 and 16.10 it worked sharing my wifi through ethernet. In network manager and changed the IPv4 Settings tab, Method: "Shared to other computers" After upgrading to 17.04 it stopped working, so did a clean install, but still not able to share. My ethernet (wired) connection just turns itself off. Anyone have a solution?

1
  • I'm having the same issue. Currently I'm using manual iptables config as a workaround. – Kh40tiK May 9 '17 at 9:02
7

In Ubuntu 17.04, the dnsmasq-tools dependency has been dropped from network-manager, which results in the network sharing feature failing to work. To fix this, simply install the dnsmasq-base package.

Open Terminal and run:

sudo apt-get install dnsmasq-base

This will fix the problem. Information about the bug can be found here...

2
  • @fabby / Thank you for answer, but since it took awhile for anyone answering I installed 16.04 again, so can't confirm your fix solves the problem. Maybe someone else that tried this can confirm in this thread, and I'll then mark your answer as best answer (solved) – sortengel Jun 23 '17 at 13:15
  • @sortengel: Blomb answered your question. I just edited it for clarity. Since June 15 this answer has received 5 upvoted that it helped other users, so click the little check-mark to mark this problem as [accepted]. ;-) – Fabby Jun 26 '17 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.