10

I just installed the latest version of Ubuntu Budgie and I can't get Alt+Shift to switch keyboard layouts. I write articles almost every day using English and Greek and it's pretty annoying to change the language using Super+Space.

Is there a way to switch keyboard layouts using Alt+Shift?

3 Answers 3

14

In Ubuntu Budgie 17.04, you would have noticed that using the GUI Settings - Keyboard - Typing - Switch to Input Source does not respond to a ALT+Shift by itself. You need a third keystroke.

However you can go behind the scenes and install the package dconf-editor and edit one or both of the following keys to get things working:

Go to org.gnome.desktop.wm.keybindings

change switch-input-source to ['<Alt>Shift_L']

Likewise the key switch-input-source-backward change to ['<Shift>Alt_L']

2
  • 5
    BTW, you must run it from your user not from root (sudo -i). Offtopic for devs: OMG! 2017 year. Gnome & Budgie and others Developers, please make "ALT SHIFT" GREAT AGAIN! Why i need do this stuff every time when i reinstall the system. Its very annoing! Plssssss. And make a shortcut into "Regional and Language settings" to chose this keys....
    – Amaroc
    Jul 9, 2017 at 16:12
  • O God, thanks! In my case I used to ['<Alt>Shift_L', '<Shift>Alt_L'] combination for switch-input-source, and switch-input-source-backward is empty. So I use only two languages. Sep 6, 2017 at 8:13
2

Because I like commmand line (fast) solutions, I tried the above gsettings command, but had to modify it:

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['<Alt>Shift_L']"
1

By default, it is Super+Space (same as on MacOS X). You can run this terminal command to change it.

gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['&lt;Alt&gt;Shift_L', '&lt;Super&gt;Shift_L']"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .