7

When I double click the .deb file it opens up in the Ubuntu Software app.

However, clicking the "Install" button doesn't do anything - no popups or errors, like I didn't even click it.

I can install the packages from the terminal by running

sudo dpkg -i *package_name*
sudo apt-get install -f

But I'd like to have my Ubuntu Software fixed. Any ideas?

5

Use gdebi to install packages. How to install:

sudo apt install gdebi

Solved the problem for me.

  • I guess that there is no other way for now, i tried a lot of stuff but i couldn't fix it.... Gdebi appears to be working fine for now. – IanDess Apr 27 '17 at 15:48
  • yes, i guess they are working on a fix. – Nadav Tasher Apr 27 '17 at 16:31
  • To open and install the deb file using gdebi via double-clicking the file, you'll need to set gdebi as the default application for opening deb files: Right-click a deb file, click Properties, then the Open With tab and select Gdebi from the list of applications. – Thuggish Nuggets Jan 4 '18 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.