0

I am running Ubuntu Xenial (16.0.4 LTS) both on my laptop and my server. I have strengthened security on the server using the techniques described here and here.

I am able to SSH from my laptop to the server, using the default SSH port (22), but when I try any other number, the connection times out:

$ ssh -vvv phreakster@magicbox -p XXXX
OpenSSH_7.2p2 Ubuntu-4ubuntu2.1, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "magicbox" port XXXX
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to magicbox [192.168.1.100] port XXXX.
debug1: connect to address 192.168.1.100 port XXXX: Connection timed out
ssh: connect to host magicbox port XXXX: Connection timed out
phreakster@CEBERUS:~$ 

I have modified and updated my /etc/ssh/sshd_config and successfully restarted the SSH daemon.

Why can't I SSH into the server using another port number?

[[Edit]]

From some of the feedback I received, I thought this may be a firewall related problem, so I logged into the server (from the machine itself), and typed the following:

sudo ufw allow 4[XXX]/tcp

WARN: Duplicate profile 'Apache', using last found WARN: Duplicate profile 'Apache Secure', using last found WARN: Duplicate profile 'Apache Full', using last found Rule added Rule added (v6)

phreakster@CEBERUS:~$ sudo ufw numbered

WARN: Duplicate profile 'Apache', using last found WARN: Duplicate profile 'Apache Secure', using last found WARN: Duplicate profile 'Apache Full', using last found Status: active

To Action From --- ------ ---- 22 ALLOW Anywhere 4XXX ALLOW Anywhere 22 (v6) ALLOW Anywhere 4XXX (v6) ALLOW Anywhere

I then restart the SSH service:

sudo service ssh restart

Here is the SSH session console debug output when I attempt to login from my laptop:

phreakster@CEBERUS:~$ ssh -vvv phreakster@magicbox -p 4XXX
OpenSSH_7.2p2 Ubuntu-4ubuntu2.1, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: resolving "magicbox" port 4XXX
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to magicbox [192.168.1.100] port 4XXX.
debug1: Connection established.
debug1: identity file /home/phreakster/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/phreakster/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/phreakster/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/phreakster/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/phreakster/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/phreakster/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/phreakster/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/phreakster/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.1
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.2p2 Ubuntu-4ubuntu2.1
debug1: match: OpenSSH_7.2p2 Ubuntu-4ubuntu2.1 pat OpenSSH* compat 0x04000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to magicbox:4XXX as 'phreakster'
debug3: put_host_port: [magicbox]:4XXX
debug3: hostkeys_foreach: reading file "/home/phreakster/.ssh/known_hosts"
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,ext-info-c
debug2: host key algorithms: ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,ssh-rsa-cert-v01@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519,rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc,3des-cbc
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,aes128-cbc,aes192-cbc,aes256-cbc,3des-cbc
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1
debug2: host key algorithms: ssh-rsa,rsa-sha2-512,rsa-sha2-256
debug2: ciphers ctos: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: ciphers stoc: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com
debug2: MACs ctos: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,zlib@openssh.com,zlib
debug2: compression stoc: none,zlib@openssh.com,zlib
debug2: languages ctos: 
debug2: languages stoc: 
debug2: first_kex_follows 0 
debug2: reserved 0 
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: rsa-sha2-512
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ssh-rsa SHA256:6hMkyfTTLjmxw1l7t1N6QdyQ39/asNr3ysnf6YiZF90
debug3: put_host_port: [192.168.1.100]:4XXX
debug3: put_host_port: [magicbox]:4XXX
debug3: hostkeys_foreach: reading file "/home/phreakster/.ssh/known_hosts"
debug3: hostkeys_foreach: reading file "/home/phreakster/.ssh/known_hosts"
debug1: checking without port identifier
debug3: hostkeys_foreach: reading file "/home/phreakster/.ssh/known_hosts"
debug3: record_hostkey: found key type RSA in file /home/phreakster/.ssh/known_hosts:1
debug3: load_hostkeys: loaded 1 keys from magicbox
debug3: hostkeys_foreach: reading file "/home/phreakster/.ssh/known_hosts"
debug3: record_hostkey: found key type RSA in file /home/phreakster/.ssh/known_hosts:2
debug3: load_hostkeys: loaded 1 keys from 192.168.1.100
debug1: Host 'magicbox' is known and matches the RSA host key.
debug1: Found key in /home/phreakster/.ssh/known_hosts:1
debug1: found matching key w/out port
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug2: set_newkeys: mode 0
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS received
debug2: key: /home/phreakster/.ssh/id_rsa (0x5632e238dcc0), agent
debug2: key: /home/phreakster/.ssh/id_dsa ((nil))
debug2: key: /home/phreakster/.ssh/id_ecdsa ((nil))
debug2: key: /home/phreakster/.ssh/id_ed25519 ((nil))
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<rsa-sha2-256,rsa-sha2-512>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey
debug3: start over, passed a different list publickey
debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/phreakster/.ssh/id_rsa
debug3: send_pubkey_test
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 60
debug1: Server accepts key: pkalg rsa-sha2-512 blen 535
debug2: input_userauth_pk_ok: fp SHA256:bmRy0HPjGc4St7qkhRk8od6P+2+EruyEAutwGTtpGL8
debug3: sign_and_send_pubkey: RSA SHA256:bmRy0HPjGc4St7qkhRk8od6P+2+EruyEAutwGTtpGL8
sign_and_send_pubkey: signing failed: agent refused operation
debug1: Trying private key: /home/phreakster/.ssh/id_dsa
debug3: no such identity: /home/phreakster/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /home/phreakster/.ssh/id_ecdsa
debug3: no such identity: /home/phreakster/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /home/phreakster/.ssh/id_ed25519
debug3: no such identity: /home/phreakster/.ssh/id_ed25519: No such file or directory
debug2: we did not send a packet, disable method
debug1: No more authentication methods to try.
Permission denied (publickey).

[[Edit 2]]

I also, did the following:

  • removed the ufw rule allowing access to server on port 22
  • added ufw rule allowing access on port 4XXX
  • modified /etc/ufw/applications.d/openssh-server and changed port from 22 to 4XXX

I restarted SSHD, adn I still get the error debug messages shown earlier in this question.

So, what do I have to do, to connect using SSH, to a remote server using a non standard port?

[[UPDATE]]

After all the experimentation above, trying to resolve the issue by myself, now I can't even log into the server using port 22 - FML!

  • Do you have some firewall rules on server/client? – Romeo Ninov Apr 26 '17 at 9:34
  • @RomeoNinov Not as far as I'm aware - although I rember laearning about IP tables etc on that machine - about 18 months ago :/ – Homunculus Reticulli Apr 26 '17 at 9:41
  • 2
    After restarting ssh, you're still able to ssh using port 22? If that's the case it's mean you didn't config your ssh server correctly, use netstat to make sure your server is listening on the correct port. – Ravexina Apr 26 '17 at 9:48
  • You can add a port to the sshd config file and restart the service, but, like Romeo suggested, the port must not be blocked by a firewall AND not already be in use by some other application. Oh, and don't forget: The first 1000 ports are reserved for specific applications, so choose wisely grasshopper... – user680858 Apr 26 '17 at 9:50
  • What errors do you see on server? – Jakuje Apr 26 '17 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.