3

having an issue with the dashboard where applications don't show app in the applications lense or when searched. Tried everything in these topics:

Applications not showing in Unity Dash

Dash (from Unity) does not showing Applications

But nothing has worked so far. Would really wat to avoid reinstalling everything since i use Vivaldi and there is no where to export my stuff from it. Using 16.04

Edit: All apps aren't being displayed, only show files and web results. Checked the filters: applications is enabled

Edit 2: after a reboot got a crash report, might be related since the culprit of the crash was unity-lens-loader. Will try to purge and see what happens.
Could not purge it, unity-lens-loader is not a package, it's a executable created by libunity9, should I purge and reinstall it?

  • All apps, only show files and web results. Checked the filters, applications is enabled – BressanFranco Apr 25 '17 at 21:36
  • Sorry but if all apps are missing, I can't help. – Diogo Gomes Apr 25 '17 at 21:53
  • @DiogoGomes no problem, just hope to find someone here that can help or if they know of ways to fully export everything from Vivaldi so that i can just reinstall the system or if they know of other ways to list all installed apps that is as elegant as dash, i'll take it – BressanFranco Apr 25 '17 at 22:21
  • The other questions you linked have many different solutions. Could you please tell us what exactly you have tried already? And could you add a screenshot of what you see please? – wjandrea Apr 27 '17 at 14:55
  • @wjandrea tried reinstalling unity-lens-applications and lens-files, tried deleting .compiz in my home folder, tried adding the mpv.desktop file in applications folder in usr/share and .local/share, tried dpkg-reconfigure, tried to delete the zeitgeist file and tried to delete the .cache folder – BressanFranco Apr 27 '17 at 23:10
0

Go to System Settings -> Security & Privacy. At Files & Applications tab click "Clear usage data". In the dialog select "From all time".

  • sorry nothing :( tried to reboot and just looked the detail of a system crash, might be related, says that unity-scope-loader has crashed – BressanFranco Apr 27 '17 at 23:17
0

The problem seems to have been fixed; the apps are showing up again. I am not sure what fixed it, but here are all the things I did before the next reboot:

I renamed unity-scope-loader to unity-scope-loader.bak in /usr/bin. I
tried to reinstall libunity9 though it always gave me an error that it couldn't overwrite unity-scope-loader. Finally, I ran sudo dpkg-reconfigure libunity9.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.