My VirtualBox Ubuntu Gnome 17.04 installation is suddenly not booting anymore. A screenshot of what I get at boot is attached, it just stays like this. The only thing that I did the last time before shutting the image down was installing the virtualbox guest additions via the provided image. I tried installing lightdm and using that; it loads, but after inserting my credentials it just silently returns to the login screen. Any suggestions? boot log

  • Maybe try booting in safe mode. Hold shift to get the menu option during boot (sometimes a bit more tricky because a virtual machine). From the menu choose "Advanced options" and then the line with "(recovery mode)". It then will boot and give you some options. Hopefully it can help you out. Good luck! – E.F. Nijboer Apr 25 '17 at 23:47
  • I believe this is a bug and should be reported to the developers of Virtual Box. – Takkat Apr 26 '17 at 9:29
  • I removed the guest editions and it fixed the problem. – Pilot6 May 6 '17 at 8:02

For anyone still experiencing this issue and unable to get to your VM's terminal. Disabling "Enable 3D Acceleration" from VirtualBox Manager worked for me.

| improve this answer | |
  • I'm used to setting up 3D acceleration on my Ubuntu guests under VirtualBox as the last step in getting their UI performance up to par. This time, with 17.10, guest additions didn't make a positive impact on very noticeable keyboard lag and I was hoping 3d acceleration was the missing piece, but I guess not that either. So now I have no idea why 17.10 is slow as molasses in Virtualbox under the same setup where 16.04 was crisp and quick. – cdaddr Mar 10 '18 at 14:49
  • 1
    @cdaddr I believe that's a problem currently in Gnome on 17.10 that VirtualBox is not liking too much. See askubuntu.com/questions/967000/… – lubumbax Mar 22 '18 at 20:04

For those who installed the guest additions from the VBoxGuestAdditions.iso (inserted in the CD-ROM drive) and got in the situation described in this post, this is how I removed them from the command line:

  • Switch to a console (Ctrl+Alt+F2).
  • Make sure that the guest additions CD-ROM is inserted.
  • Run the following:

    sudo mount -t iso9660 /dev/cdrom /cdrom
    sudo /cdrom/VBoxLinuxAdditions.run uninstall

I got into this issue with VBox 5.1.22 . Hopefully there will be a fix soon.

| improve this answer | |
  • 7
    You do not need to mount. Just run sudo /opt/VirtualBox*/uninstall.sh – Pilot6 Jun 2 '17 at 21:31
  • I was only able to switch to the console using a different key combination, I think it was Ctrl+Alt+F3 or Ctrl+Alt+F4 – Jon Onstott Nov 16 '17 at 20:30

Same happened to me, first I tried to install all virtual box additions from the PPA and it didn't fix. Then I removed all and started working again:

sudo apt-get install virtualbox-guest-* && sudo reboot

then remove all:

sudo apt-get remove virtualbox-* && sudo reboot
| improve this answer | |
  • How did you get into the position to be able to actually access the terminal to run those commands? – Timothy Swan Nov 7 '17 at 23:22
  • Control + Alt + F[2-8] should get you real terminals. It'll prompt you for a username and then will run your bashrc etc. – Chris Pfohl Feb 21 '18 at 15:26

When you get to that screen hit Ctrl+Alt+F2. Log in with your credentials and then hit:

sudo apt-get remove virtualbox-guest-x11

To restart the machine:

sudo reboot

That will remove the virtualbox display driver, letting you able to log in normally and leaving the functionality of shared clipboard and drag and drop.

| improve this answer | |
  • thanks, I had already uninstalled the whole virtualbox guest additions but it did not fix the problem. As I needed that machine for work and could not find solutions online I just installed regular ubuntu (i.e. with unity) on top of it, which kept most of my software installed. I'm leaving the question open just in case someone stumbles on a similar problem and finds a solution. – manuhalo Apr 28 '17 at 7:51

Just disabling 3D Acceleration solved my problem.

Machine -> Settings -> Display -> untick Enable 3D Acceleration
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.