1

I installed gnome-shell under Ubuntu 17.04 and switched to the gdm3 display manager. Wanted to try out the gnome shell due to the upcoming changes. Rebooted machine and display is a blank. No login prompt just a blank screen.

My setup is a Dell XPS M1330 laptop connected to a Dell S2440L monitor via a VGA connection. Need to use monitor since laptop screen is non functioning.

4
  • I did the same (switching from Unity to Gnome Shell) up to the change of display manager, but luckily saved my system using Clonezilla before trying to change to gdm3. It made my system unusable (with Intel graphics card). So I restored my 2 partitions. Although gdm3 looks fantastic on Ubuntu Gnome 17.04 (which has several other more essential problems of stability) it seems we have to await at least six months for it... – Sadi Apr 26 '17 at 19:02
  • Used grub to change display manager, back to unity. – David M Apr 27 '17 at 23:37
  • Wiped off Ubuntu 17.04 and reinstalled Ubuntu Gnome 17.04 (solving other problems) which looks very much like Unity with several tweaks enabled by extensions ;-) – Sadi Apr 28 '17 at 13:14
  • You have gnome-desktop installed? see: askubuntu.com/questions/906643/… – rafrsr May 4 '17 at 20:37
4

This is a well-known bug that has recently been fixed for 17.04 and earlier in the package nvidia-graphics-drivers-375.

Check this link for more details: https://bugs.launchpad.net/ubuntu-gnome/+bug/1559576

Installing that package should fix your issue.

Ubuntu 17.10 seems to still have the issue as of July 2017. For more details on that, check this link: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1705369

Update: the latest bug (1705369) has a workaround, check the the link for more details. Also, like @Tim Richardson mentioned in the comments, lightdm works. From the terminal, execute the following:

sudo dpkg-reconfigure lightdm

then choose lightdm.

2
  • 1
    It's still broken for me, on an Optimus laptop., if you are using modeset=1 to access the new Prime sync (tear free) functionality. There are a mass of bug reports, it's hard to wade through them but it seems that modeset=1 causes gdm3 to start a wayland session, and it must be harder than it seems to not do this . lightdm doesn't try to do this, so that's the workaround. – Tim Richardson Jul 27 '17 at 8:11
  • Thanks @TimRichardson, I've updated the answer. The bug report (1705369) mentions a lot of details about the issue including the fact that lightdm works, it is worth a read. – Amri Jul 27 '17 at 9:08
0

To get things working, the following packages need to be installed:

    sudo apt install ubuntu-gnome-desktop gnome-shell gdm3

Optionally, you may also want to install gnome, although this does not seem necessary if gnome-shell has been installed. Hibernation did not work with lightdm, hence the need to install through the package gdm3.

But then there was also a need to reinstall nvidia proprietary drivers Following instructions of http://ubuntuhandbook.org/index.php/2015/01/install-nvidia-346-35-ubuntu-1404/ with slight modifications:

  1. remove the current nvidia driver running

    sudo apt purge nvidia-* && sudo apt autoremove
    

    note the version of the nvidia driver you're removing, say nvidia-xyz

  2. blacklist nouveau by opening /etc/modprobe.d/blacklist-nouveau.conf with your favourite editor and inserting

    blacklist nouveau
    blacklist lbm-nouveau
    options nouveau modeset=0
    alias nouveau off
    alias lbm-nouveau off
    
  3. Disabling the kernel nouveau (not sure whether this is necessary, though, but it does not seem to do harm to the installation)

    echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
    sudo update-initramfs -u
    
  4. Reboot the computer and login to a terminal without display manager, e.g., CTRL+ALT+F1. Unfortunately, the display manager has been started already (still available under CTRL+ALT+F7), thus the service need to be stopped

    sudo service lightdm stop
    
  5. Activating gdm (gdm3) as default display manager.

    sudo dpkg-reconfigure gdm3
    

    This will return an error saying that the service has not been started and hence the display manager could not be switched. No worries, the switch will be carried out upon reboot.

  6. Re-installing the nvidia driver that has been removed earlier, where xyz is the version that was uninstalled under the first step.

    sudo apt install nvidia-xyz
    
  7. Reboot your system

    sudo shutdown -r now
    

This made me have a completely functional system with gnome-shell desktop and gdm display manager. Bonus was a fully operational hibernate. Hope this helps.

1
  • It is still broken if you want to use the nvidia modeset driver, which you need to use if you want to use Prime sync with nvidia optimus laptops (tear free graphics in Optimus mode). – Tim Richardson Jul 26 '17 at 1:10
0

Just booting into terminal mode ttyl and after executing command purge nvidia-390 and installing it once again solved this long mess.

1
  • Maybe you can explain a little further and set this as answer. – davidbaumann Mar 1 '18 at 18:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.