7

I just installed a new kernel on Ubuntu GNOME 17.04 that came in through the normal updates. However, it is now stuck for a while on the following line:

Setting up linux-headers-4.10.0-20-generic (4.10.0-20.22) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 4.10.0-20-generic /boot/vmlinuz-4.10.0-20-generic

Something seems to hang the process. Does someone know what could cause this?

EDIT: This is the content of /boot as requested:

abi-4.10.0-19-generic     grub                          System.map-4.10.0-19-generic
abi-4.10.0-20-generic     initrd.img-4.10.0-19-generic  System.map-4.10.0-20-generic
config-4.10.0-19-generic  memtest86+.bin                vmlinuz-4.10.0-19-generic
config-4.10.0-20-generic  memtest86+.elf                vmlinuz-4.10.0-19-generic.efi.signed
efi                       memtest86+_multiboot.bin      vmlinuz-4.10.0-20-generic

EDIT 2: Just tried purging the new kernel but got this:

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

Using that command returns me to the original problem. I am stuck now :(

  • You use graphical update-manager for this? Or commandline and apt? – davidbaumann Apr 25 '17 at 10:41
  • Both. I first tried the graphical updater, but when I noticed it stuck I tried the command line. Same result (and output) however.. – Gladen Apr 25 '17 at 10:47
  • Please post ls /boot/ – davidbaumann Apr 25 '17 at 11:04
  • @davidbaumann See my question edit for the output :) – Gladen Apr 25 '17 at 11:08
  • If DKMS build kernel failed, it will leave the make.log for you to tell what happened. The log will be at /var/lib/dkms/<your_module_name>/<your_module_version>/build/make.log – davidbaumann Apr 25 '17 at 11:17
4

I just "fixed" it. I was running Ubuntu with my Nvidia Graphics card all the time. I switched back to the build-in Intel graphics with the Nvidia Control Center and rebooted. After this, the configuration of the kernel didn't hang and everything seems to work as normal.

So if you also have this issue, try to change back to Intel graphics before running dpkg --configure -a

  • This also worked for me. For those coming to this answer, I ended up trying to perform this dist-upgrade because the gnome apps kept failing to open with an exit code of 139 and constantly reporting VMA errors. – Christian Di Lorenzo Jan 23 '18 at 3:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.