0

I am trying to backup my photos from my windows computer to my ubuntu server. But each time I run rsync it transfers all the files each time. I have researched how to modify the rsync command, but I have yet to find anything that works.

This is how I mount the windows folder in fstab:

//WIN/share /media/windowsshare cifs credentials=/home/jason/Documents/win.credentials,sec=ntlmssp

This is my rsync command:

rsync -h -v -r -P -t -O --ignore-existing /media/windowsshare/photos /media/mediadisk1/data/photos

I have also tried adding --size-only and --checksum to the rsync command because I read in a post that Ubuntu's timestamp is different than windows and that can cause syncing problems, but those did not help.

0

Try

sudo rsync --archive --verbose --human-readable --itemize-changes --progress --no-o --no-g --delete --delete-excluded /media/windowsshare/photos /media/mediadisk1/data/photos 2>&1 | tee -a /home/XXX/rsync-output.txt

On location /home/XXX/rsync-output.txt command will create log file and you can see what is done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.