0

In Ubuntu Fn+F2 is used as shortcut to rename a file. But this is not working for me. Probably I changed some keymap or configuration somewhere. How can I make this work again? How can I set Fn+F2 as file rename shortcut?

  • Can you provide some more information in general, if not specific, as to how you may have "changed some keymap" settings? Were you deliberately attempting to change keymaps? If so, how were you going about it? – b_laoshi Apr 25 '17 at 0:46
  • On some laptops, you can change whether the Fn key is needed or not. Try F2 without Fn to see if you can rename that way. If that works, the meaning of Fn has been changed. – Chai T. Rex Apr 25 '17 at 0:49
2

I think it's possible that you're just misremembering the correct shortcut.

To rename a file in Nautilus, simply select the file and press F2 (without pressing the Fn key).

  • 2
    some laptops put media keys on the F1-FX keys (you press Fn-F1 for volume-up, Fn-F2 for volume-down, etc). a common trick is to then reverse that (in firmware) so F1 gets volume-up and you have to press Fn-F1 for the OS to see F1. sometimes there's a firmware/BIOS setting to control which way the keys default, sometimes not. (i think some systems can be software controlled, via kernel driver parameter or XKB. heavily hardware dependent.) perhaps this user's setting has changed recently. – quixotic Apr 24 '17 at 23:09
  • But in my lenovo laptop F1, F2, F3 used for volume mute, up and down. And fn+F2 was the shortcut for renaming. Anyway, F2 or fn+F2 none of them works as renaming shortcut – asdfkjasdfjk Apr 24 '17 at 23:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.