5

I've been trying to get natural scrolling running, but there is no option in the settings. I have looked at the parameters via synclient, and there is no option for natural scrolling there either, as in normal Ubuntu. Any ideas?

4

You can try this. Notice 6 and 7 are swapped.

NaturalScrolling:

echo "pointer = 1 2 3 5 4 7 6 8 9 10 11 12" > ~/.Xmodmap && xmodmap ~/.Xmodmap

Information from: https://andym3.wordpress.com/2011/09/03/the-one-line-method-of-getting-natural-scrolling-in-linux/

  • Much easier than other answers and no restart required. Works on 16.04. +1 – Prime624 Mar 14 '18 at 21:11
  • this solution works!! – Deepak Yadav Aug 29 '18 at 1:33
4

As @Pilot6 suggested, make an edit to /usr/share/X11/xorg.conf.d/40-libinput.conf. But add to to BOTH the 'pointer' and 'touchpad' sections.

Find the 'pointer' section and add the "Natural Scrolling" option there.

Section "InputClass"
    Identifier "libinput pointer catchall"
    MatchIsPointer "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "NaturalScrolling" "true"  # <-- add this line
EndSection

Do the same for the touchpad section:

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "NaturalScrolling" "true" # <-- add this line
EndSection

Save these changes, reboot, and natural scrolling should now work for you.

0

Run in a terminal

sudo -H gedit /usr/share/X11/xorg.conf.d/40-libinput.conf

and add

Option "NaturalScrolling" "true"

to the end of the touchpad section of the file (before EndSection).

In Ubuntu 17.04 libinput is used. It does not have GUI settings yet.

  • I had to add that 'Option "Natural Scrolling" "true" ' to the pointer section, in order for it to work. ( I actually ended up adding it to both the pointer and touchpad sections.) – Gino Mar 5 '18 at 13:16
  • Only adding it to the end of the touchpad section didn't work for me in Lubuntu 18.04 – rubo77 Aug 9 '18 at 19:06
0

It is better to add a new configuration file for X11 libinput. The filename should start from maximum counter + 1 to be proceeded the last. For example, I have a bunch of files with default configurations:

$ ls -l /usr/share/X11/xorg.conf.d/
-rw-r--r-- 1 root root   92 мар 20 15:02 10-amdgpu.conf
-rw-r--r-- 1 root root 1350 апр 13 18:31 10-quirks.conf
-rw-r--r-- 1 root root   92 мар 20 15:17 10-radeon.conf
-rw-r--r-- 1 root root  945 авг  1 11:28 40-libinput.conf
-rw-r--r-- 1 root root  590 мар  7  2017 51-synaptics-quirks.conf
-rw-r--r-- 1 root root 1751 мар  7  2017 70-synaptics.conf

So I added a new configuration file to the end of the list:

-rw-r--r-- 1 root root  113 авг  1 11:33 71-touchpad-scroll.conf

With the following content:

Section "InputClass"
        Identifier "touchpad catchall"
        Option "NaturalScrolling" "true"
EndSection
0

The listed solutions were only working for few applications on my Lenovo Z510. Add the following line to /usr/share/X11/xorg.conf.d/70-synaptics-conf under the first InputClass section:

Option "VertScrollDelta" "-90"

You can also test if this is working by executing the following command:

synclient VertScrollDelta=-90

However, the effect of the command vanishes after you log out. So it is preferable to edit the configuration file.

Source: https://diggle.tech/howto/2017/06/enable-natural-scroll-reverse-touchpad-on-lubuntu/

0

This worked for ubuntu 16.04 (If you have gnome desktop environment)

gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.