0

How do I install lazarus-1.6.4-fpc-3.0.2 34/64 bit on Ubuntu 17.04? I have previously installed Lazarus without problems on Ubuntu 16.04 and earlier versions; but, installation fails with Ubuntu 17.04. Something changed. Help greatly appreciated.

More Details:

  1. Downloaded the three DEB Lazarus from https://sourceforge.net/projects/lazarus/files/Lazarus%20Linux%20amd64%20DEB/Lazarus%201.6.4/
  2. Saved to Downloads directory.
  3. Double clicked on first file. The file was set to open with "Ubuntu Software".
  4. A window opens with an "install" button.
  5. Clicked on the "install" button.
  6. Nothing happens, no errors shown, no authorization dialog box.
  7. Tried the other two files, same result; nothing!!

With earlier versions of Ubuntu, Lazarus was successfully installed using the "Ubuntu Software" application. However; with Ubuntu 17.04, the same "Ubuntu Software" install application does not work.

  • 4
    Please edit your question to elaborate on how you used to install Lazarus, and exact details on the failure. – user535733 Apr 24 '17 at 13:28
  • Download the .deb file from here and install it. if you're having trouble installing .deb files mention that in your question by editing it. – Sumeet Deshmukh Apr 24 '17 at 13:33
0

Be sure that libgtk2-dev is installed, and then open a terminal. Use cd to go to where you downloaded the 3 files and install them using this command:

dpkg -i fpc_3.0.2-170225_amd64.deb fpc-src_3.0.2-170225_amd64.deb fpc_3.0.2-170225_amd64.deb

This method worked for me in Ubuntu 17.04.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.