5

Firefox always starts at 0 vol as if that is supposed to be the default or something.

Any time I adjust the volume in firefox, I have to open pulse audio and turn the volume back up for firefox.

Any time a new video comes on Youtube, I have to open pulse audio and turn the volume back up for firefox.

Any time I skip forward or back in a playing video or track, I have to open pulse audio and turn the volume back up for firefox.

How can I set the default volume to FULL VOLUME?

I mean seriously, isn't that why there is a system volume?

Any help would be appreciated.

2
  • It may be just a user setting in your .config/pulse. Try to remove it, see askubuntu.com/questions/201780/…
    – Takkat
    Apr 24, 2017 at 7:53
  • @Takkat I tried that and it didn't work, however, I did find a solution.
    – mchid
    Apr 25, 2017 at 13:12

2 Answers 2

5

I found a solution!

First, I opened firefox went to about:config

searched for: media.default_volume

double clicked media.default_volume

and finally, I changed the value to 5

Additionally, I saw a solution somewhere else that suggested using 2.0 for media.volume_scale,

make sure that media.volume_scale is set to 1.0

2
  • It solved the mute-on-pause-error in 78.14.0esr at debian 11 by setting: media.default_volume 10 and media.volume_scale 1.0
    – Frank
    Oct 3, 2021 at 10:23
  • For the admins, please see my edit.
    – mchid
    Dec 21, 2021 at 20:25
3

In my system, Firefox for some reason did not have the permission to play sounds. To change it: right click on the icon of the app-> Show Details -> Click on the app -> Permissions -> play sound's check

2
  • This is actually a different issue. For my problem, I would have to increase the volume after starting firefox every time so the permissions were fine. I think the permission issue is for the snap version of firefox.
    – mchid
    Dec 21, 2021 at 19:11
  • As commented here on the ubuntu forums, "The main advantage of snaps is that they're sandboxed. The main disadvantage of snaps is that they're sandboxed".
    – mchid
    Dec 21, 2021 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.