1

Just installed Ubuntu 17.04 today on my Spectre x360 laptop, but its taking about 2 minutes to boot (Windows took ~10 seconds).

As suggested here: How to fix very slow Ubuntu booting? I ran the dmesg command, here is an excerpt of the output where I believe the problem is:

[    5.771049] audit: type=1400 audit(1492997122.163:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=747 comm="apparmor_parser"
[    5.772152] audit: type=1400 audit(1492997122.163:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=751 comm="apparmor_parser"
[    5.773675] audit: type=1400 audit(1492997122.163:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=752 comm="apparmor_parser"
[    5.773677] audit: type=1400 audit(1492997122.163:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=752 comm="apparmor_parser"
[   16.086226] intel-vbtn INT33D6:00: unknown event index 0xcd
[   28.153199] intel-vbtn INT33D6:00: unknown event index 0xcd
[   95.264415] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   95.264417] Bluetooth: BNEP filters: protocol multicast
[   95.264420] Bluetooth: BNEP socket layer initialized
[   95.331589] haswell-pcm-audio haswell-pcm-audio: FW loaded, mailbox readback FW info: type 01, - version: 00.00, build 77, source commit id: 876ac6906f31a43b6772b23c7c983ce9dcb18a19
[   95.429468] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[   95.431987] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   95.432503] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   95.497193] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   95.497668] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   95.522825] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[   95.531535] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   95.531986] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled
[   95.604347] iwlwifi 0000:02:00.0: L1 Enabled - LTR Enabled

I really wasn't able to find much on what intel-vbtn INT33D6:00: unknown event index 0xcd is or how to fix it so any suggestions would be helpful.

1

Update

As mentioned in the comments, if you have an encrypted home, Ubiquity still creates a cryptoswap partition instead of linking to the swapfile.

This can be fixed by following this guide:

Ubuntu Desktop 17.04 64bit slow boot

Original Workaround

First off I want to clarify that I have the same issue and so I want to give some further details on the hardware (for all those who might be able to debug the error):

  • HP Spectre x360 15-bl002ng
  • Intel i7-7500U
  • Nvidia 940MX
  • NVME PCIe SSD (Samsung I believe)

Second:

I found a workaround by setting the systemd timeout to 10s instead of 90s. To do so, edit /etc/systemd/system.conf. In my case I had to uncomment the following two lines set the timer:

DefaultTimeoutStartSec=10s
DefaultTimeoutStopSec=10s

After a reboot, the system is up after about 10 seconds. May be warned however, that such a low timeout may cause other, more severe problems. So do that at your own risk!

Third:

For all those who can actually figure out what might be wrong I would like to add what I found out:

After I upgraded to kernel 4.11 RC8 (to fix intel-vbtn INT33D6:00: unknown event index 0xcd, comment #24) I got way more debug info and so noticed that the boot sequence is actually stuck at A start job is running for [some dev + UUID presumably].

I stumbled across a German Debian forum where the error seems to be caused by a mismatch of the actually UUID of the swap partition reported by sudo blkid and the used UUID by fstab.

However, since 17.04 Ubuntu uses a swapfile instead of a partition, I am clueless on how to fix this issue.

  • Do you have an encrypted home partition? Then it could potentially be this bug askubuntu.com/questions/905031/… – Amrit Kahlon May 6 '17 at 0:42
  • I actually do have an encrypted home, so thanks a lot! I also updated the answer to include the link – Znert May 6 '17 at 14:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.