1

I'm running Ubuntu 16.04 with CPU: i7-6700. Even with one of the cores sitting on 100% utilisation cpufreq-info reports.

...
analyzing CPU 7:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 7
  CPUs which need to have their frequency coordinated by software: 7
  maximum transition latency: 0.97 ms.
  hardware limits: 800 MHz - 3.50 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 3.50 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.

Each CPU shows 800 MHz. How do I get my CPU frequency to increase under load?

  • Dell LapTops sometimes limit CPU frequencies if they do not detect the proper Dell AC adapter. – Doug Smythies Apr 24 '17 at 13:50
  • I have the same problem: cpufeq analyzing CPU 0..3: current policy: frequency should be within 1.20 GHz and 1.36 GHz. The governor "performance" may decide which speed to use current CPU frequency is 284 MHz (asserted by call to hardware) DELL XPS 15 and with "Ubuntu 16.04: uname -a Linux Dell-XPS-L502X 4.8.0-52-generic #55~16.04.1-Ubuntu SMP Fri Apr 28 14:36:29 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux lsb_release -a LSB Version: core-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-amd64 Ubuntu 16.04.2 LTS xenial The same on 16.10 or 17.04 – Vedavrat May 22 '17 at 13:29
  • I have the same problem on DELL XPS 15 many years -- with different versions of Ubuntu... Usually i occurs after "Suspend"... and clears after "Reboot"... – Vedavrat May 31 '17 at 9:37
2

Thanks for the suggestions. It seems to be an issue that a few have come up against where the processor gets stuck in a throttled state. I've tried the suggested solution of removing the battery and it is now running at full speed again. Unfortunately this has the effect of clearing other bios settings. This was on a Dell XPS 9550.

| improve this answer | |
  • It's a miricle, :-) you advice helped ! Thank you. [DELL XPS 15 L502x ; "Ubuntu 16.04.2 LTS" ; Linux 4.8.0-54-generic #57~16.04.1-Ubuntu SMP 24-May-2017 x86_64 GNU/Linux...] – Vedavrat Jun 19 '17 at 9:27
0

It's possible that it is a hardware problem: the BIOS may limit CPU speed for various reasons, including overheating or perhaps even a loose connector for a fan, a temperature sensor or a chassis intrusion sensor. Whether or not it can do that depends on the manufacturer, most likely. Anyway, Enhanced SpeedStep should be able to function independently from any CPU frequency governor. Maybe it's just reading it wrong. Does the computer feel excessively sluggish to you? If not it may well be working properly. Perhaps it's a good idea to cross-check by running "lscpu" in the terminal, and see what it has to say about current speed.

| improve this answer | |
  • Thanks for your reply. Yes it feels slow. lscpu also indicates around 800 MHz under load. – coops Apr 24 '17 at 1:14
  • What make and model is the pc? Also, did you install any software that does power saving? Again, normally the CPU should just go to the max when needed when left to its own devices. – Thomas Lust Apr 24 '17 at 12:40
0

As a temporary solution, I do following: sudo -i for x in /sys/devices/system/cpu/cpu[0-3]/cpufreq; do echo 3400000 > $x/scaling_max_freq; done for x in /sys/devices/system/cpu/cpu[0-3]/cpufreq; do echo 2700000 > $x/scaling_min_freq; done

After that i do reinserting power (remove - insert), and then frequency increases higher than 800 MHz.

| improve this answer | |
  • Now (Linux Dell-XPS-L502X 4.8.0-54-generic #57~16.04.1-Ubuntu SMP May 24 2017 x86_64 GNU/Linux) such "work-around" does not help already... – Vedavrat Jun 17 '17 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.