2

I wanted to try an application (Kamoso) but its installation failed, and now a system tray icon tells me:

An error occurred ... run Package Manager or apt-get to see what is wrong. Error: BrokenCount>0

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  kde-config-telepathy-accounts
The following NEW packages will be installed:
  kde-config-telepathy-accounts
0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.
2 not fully installed or removed.
Need to get 0 B/148 kB of archives.
After this operation, 808 kB of additional disk space will be used.


  Do you want to continue? [Y/n] y
    (Reading database ... 1330003 files and directories currently installed.)
    Preparing to unpack .../kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_i386.deb ...
    Unpacking kde-config-telepathy-accounts (4:15.12.3-0ubuntu1) ...
    dpkg: error processing archive /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_i386.deb (--unpack):
     trying to overwrite '/usr/share/accounts/services/google-im.service', which is also in package account-plugin-google 0.12+16.04.20160126-0ubuntu1
    Processing triggers for libc-bin (2.23-0ubuntu7) ...
    Errors were encountered while processing:
     /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

Ubuntu software centre fails repairing:

    installArchives() failed: (Reading database ... 
(Reading database ... 100%
(Reading database ... 1330003 files and directories currently installed.)
Preparing to unpack .../kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_i386.deb ...
Unpacking kde-config-telepathy-accounts (4:15.12.3-0ubuntu1) ...
dpkg: error processing archive /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_i386.deb (--unpack):
 trying to overwrite '/usr/share/accounts/services/google-im.service', which is also in package account-plugin-google 0.12+16.04.20160126-0ubuntu1
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Errors were encountered while processing:
 /var/cache/apt/archives/kde-config-telepathy-accounts_4%3a15.12.3-0ubuntu1_i386.deb
dpkg: dependency problems prevent configuration of kde-telepathy-minimal:
 kde-telepathy-minimal depends on kde-config-telepathy-accounts (>= 15.04.0); however:
  Package kde-config-telepathy-accounts is not installed.

dpkg: error processing package kde-telepathy-minimal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of kde-telepathy:
 kde-telepathy depends on kde-telepathy-minimal (= 15.04.20ubuntu1); however:
  Package kde-telepathy-minimal is not configured yet.

dpkg: error processing package kde-telepathy (--configure):
 dependency problems - leaving unconfigured

I tried to remove or purge kde-telepathy-minimal or kde-telepathy:

$ sudo apt-get purge kde-telepathy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 kde-telepathy-minimal : Depends: kde-config-telepathy-accounts (>= 15.04.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Could you please help me remove either of the packages, as a solution to clean up this broken installation and get the package manager back to work?

  • Two packages conflict: package account-plugin-google and kde-config-telepathy-accounts. You must choose one, and uninstall the other. Read the error message carefully, and you will see this problem, and the reason for it. – user535733 Apr 24 '17 at 0:13
  • edited with my attempt to remove either of the packages – ubuntubu Apr 24 '17 at 8:51
  • 1
    Apt queues package actions, and the first error aborts the entire queue. Use dpkg to uninstall the offending (conflicting) package, then use apt to clean up the dependencies. – user535733 Apr 24 '17 at 13:27
  • I did not know that both apt and dpkg have a "remove" command. Thank you! – ubuntubu Apr 24 '17 at 15:17
3

Thanks to @user535733 for the useful comment: "Use dpkg to uninstall the offending (conflicting) package, then use apt to clean up the dependencies"

Here's how I removed the conflicting packages:

$ sudo dpkg --remove kde-telepathy
(Reading database ... 1330002 files and directories currently installed.)
Removing kde-telepathy (15.04.20ubuntu1) ...

$ sudo dpkg --remove kde-telepathy-minimal
(Reading database ... 1329999 files and directories currently installed.)
Removing kde-telepathy-minimal (15.04.20ubuntu1) ...

Afterwards I cleaned up with

sudo apt autoremove
  • Trying first to remove kde-telepathy-minimal, was not possible: guest@guest:~$ sudo dpkg --remove kde-telepathy-minimal dpkg: dependency problems prevent removal of kde-telepathy-minimal: kde-telepathy depends on kde-telepathy-minimal (= 15.04.20ubuntu1). dpkg: error processing package kde-telepathy-minimal (--remove): dependency problems - not removing Errors were encountered while processing: kde-telepathy-minimal – ubuntubu Apr 24 '17 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.